Spring Social
  1. Spring Social
  2. SOCIAL-322

spring-social-web will not deploy on JBoss 6.1 due to invalid spring-social.tld

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0.2.RELEASE
    • Fix Version/s: 1.1.0.M3
    • Component/s: None
    • Environment:
      Windows 7 / STS 3 / JBoss 6.1

      Description

      When deploying an application which uses the spring-social-web library version 1.0.2, the JBoss AS will not deploy the application due to failure to parse the spring-social.tld file. The exception stack trace is attached.

      The spring-social-web library version 1.0.1 deploys without error in JBoss 6.1
      Note, spring-social-web library version 1.0.2 deploys in JBoss 4.2.3 without issue. I understand JBoss 6 has more explicit schema checking.

      1. stacktrace.txt
        4 kB
        Barry John Williams

        Activity

        Craig Walls added a comment -

        Can you try this again with the latest Spring Social 1.1.0.BUILD-SNAPSHOT builds (or possibly even with 1.1.0.M2 builds)? I just tried deploying Spring Social Showcase (which uses that tag library and depends on spring-social-web) to JBoss EAP 6.1 and it ran without incident.

        Craig Walls added a comment -

        This appears to work fine with Spring Social 1.1.0.BUILD-SNAPSHOT deployed to JBoss EAP 6.1. It's possible that this was corrected somewhere along the way to the current 1.1.0.BUILD-SNAPSHOT, although there have been no changes to the TLD since Jan 13, 2012).

        In any case, it seems to work.


          People

          • Assignee:
            Craig Walls
            Reporter:
            Barry John Williams
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: