Spring Social LinkedIn
  1. Spring Social LinkedIn
  2. SOCIALLI-21

NetworkUpdateOperations.createNetworkUpdate uses wrong HTTP request method

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Complete
    • Affects Version/s: 1.0.0.RC1
    • Fix Version/s: 1.0.0.RC2
    • Component/s: None
    • Labels:
      None

      Description

      NetworkUpdateTemplate.createNetworkUpdate uses PUT while LinkedIn requires a POST request for this kind of operation causing error "405 Method Not Allowed". (see post-network-update)

        Activity

        Robin Sander added a comment -

        What else can I do to get this small bugfix into any official release? (there's only one line of code to change)
        I've provided a pull-request on github, see https://github.com/SpringSource/spring-social-linkedin/pull/27

        Robin Sander added a comment -

        What does it need to get this one-line fix into production?

        Craig Walls added a comment -

        I'm working it now, but...

        It's not a one-line change. I've merged the pull request and now the build fails, because the test wasn't changed to match the updates in NetworkUpdateTemplate. Normally, I'd push that effort back to you to address, but in the interest of getting this in a build, I'll fix it myself.

        Robin Sander added a comment -

        So make it two lines...
        But to be honest I didn't run any tests! Next time I promise I will and probably extend those tests where applicable.

        Craig Walls added a comment -

        It's in the latest 1.0.0.BUILD-SNAPSHOT build. Can you please test it and confirm that it works for you?

        Robin Sander added a comment -

        There's still PUT used in the latest 1.0.0.BUILD-SNAPSHOT build, I've used http://repo.springsource.org/snapshot. Maybe I have to wait a little while?

        Craig Walls added a comment -

        The build server is acting strange today. The snapshot build didn't complete as I had expected it would. I'll let you know (here) when that happens.

        Craig Walls added a comment -

        Okay...the new snapshot build just completed. Give it another shot. As you probably know, you may need to have your build force a new fetch of the snapshot build since you've already done it once today.

        Robin Sander added a comment -

        I can confirm that it works now, thanks!


          People

          • Assignee:
            Craig Walls
            Reporter:
            Robin Sander
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: