Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate
    • Affects Version/s: 3.2 GA
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None

      Description

      There are two issues:
      1. Spring ASM has no 3.2.0.RELEASE version in Maven Repo. The latest version of Spring-ASM is 3.1.3.RELEASE
      2. In Spring-Core 3.2.0.RELEASE, the class LocalVariableTableParameterNameDiscoverer has a private class ParameterNameDiscoveringVisitor which extends an interface org.springframework.asm.ClassVisitor (defined inside Spring-ASM); whereas in Spring-Core 3.1.3.RELEASE the same class extends org.springframework.asm.commons.EmptyVisitor (which is not an interface).

      Because of the issue #2, the deployment (of my WAR file) is breaking in JBoss 7.1.1

        Issue Links

          Activity

          Chris Beams added a comment -

          Hi Niranjan,

          This is by design. Please see my comments at SPR-10112. You should find that simply removing altogether the spring-asm dependency from your project will solve the problem.


            People

            • Assignee:
              Chris Beams
              Reporter:
              Niranjan Nanda
              Last updater:
              Chris Beams
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 16 weeks, 2 days ago