Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-10494

spring-web not published with Eclipse 4.2, WAS 7.0 and mvn 3

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.2 GA, 3.2.1, 3.2.2
    • Fix Version/s: None
    • Component/s: Web

      Description

      I'm having same problem as described in StackOverflow link even if I'm not the author of the question.
      I try to publish a Spring 3.2.x project with Eclipse 4.2 to a Websphere AS 7.0 (via IBM WDT 8.5.x). Using Maven 3.0.4, tried with both eclipse:eclipse and m2eclipse plugin. spring-web-*.jar gets not published on WAS but it is still there as an artifact when packaging a WAR via mvn.
      In my company it's only reproducable with this combination. If we use Tomcat instead of WAS, RAD instead of Eclipse or v3.1.x instead of v3.2.x (which was previousely the case) everything works!

        Attachments

          Activity

            People

            Assignee:
            rstoya05-aop Rossen Stoyanchev
            Reporter:
            faetzminator Marc Schmid
            Last updater:
            Spring Issues Spring Issues
            Votes:
            6 Vote for this issue
            Watchers:
            11 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Days since last comment:
              3 years, 24 weeks, 4 days ago