Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-15600

Upgrade to Objenesis 2.6 for Google App Engine Standard on Java 8 and for better JDK 9 support

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 4.3.10, 5.0 RC3
    • Component/s: Core:AOP
    • Labels:
      None
    • Last commented by a User:
      true

      Description

      App Engine Standard for Java 8 (currently in Alpha) lifted the old sandbox/API restrictions. We can now use Objenesis as-is. A recent patch was merged into Objensis to take this new environment into account.

      See https://github.com/easymock/objenesis/issues/51

      This is tracking issue to ensure that Spring core will use the new version when it becomes available on Maven.

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              juergen.hoeller Juergen Hoeller
              Reporter:
              saturnism Ray Tsang
              Last updater:
              Juergen Hoeller
            • Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                21 weeks ago