Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-15836

spring-aspects should remain on AspectJ 1.8.9 by default (since aspectjrt 1.8.10 requires Java 7+)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: 4.3.10
    • Fix Version/s: 4.3.11
    • Component/s: Core:AOP
    • Labels:
    • Last commented by a User:
      false

      Description

      Since Version 4.3.10.RELEASE `spring-aspects` depends on `aspectjrt` 1.8.10, which is compiled against Java 7 (according to Maven).

      This makes Spring Framework incompatible with Java 6.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                juergen.hoeller Juergen Hoeller
                Reporter:
                soeren.chittka Sören Chittka
                Last updater:
                Juergen Hoeller
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  46 weeks ago