Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Complete
    • Affects Version/s: 5.0 RC4
    • Fix Version/s: 5.0 RC4
    • Component/s: [Build]
    • Labels:
      None
    • Last commented by a User:
      false

      Description

      After the upgrade to Gradle 4.0, we now see the following error when executing import-into-eclipse.sh:

      FAILURE: Build failed with an exception.
       
      * Where:
      Script '/spring-framework/gradle/ide.gradle' line: 24
       
      * What went wrong:
      Execution failed for task ':spring-aspects:eclipseClasspath'.
      > Could not find matching constructor for: org.gradle.plugins.ide.eclipse.model.ProjectDependency(org.codehaus.groovy.runtime.GStringImpl, java.lang.String)
      

      Reverting to Gradle 3.5 displays the following warning:

      The ProjectDependency(String path, String gradlePath) method has been deprecated and is scheduled to be removed in Gradle 4.0. Please use ProjectDependency(String path) instead.
              at ide_7j0kvly8u2wb253k4xchxls6o$_run_closure2$_closure12.doCall(/Users/sbrannen/source/spring-framework/gradle/ide.gradle:24)
      

        Issue Links

          Activity

          Show
          sbrannen Sam Brannen added a comment - Fixed in the following GitHub commit: https://github.com/spring-projects/spring-framework/commit/1cb96f47c87cc15bfda2026dc85c7af95278c081

            People

            • Assignee:
              sbrannen Sam Brannen
              Reporter:
              sbrannen Sam Brannen
              Last updater:
              St├ęphane Nicoll
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                13 weeks, 1 day ago