Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Incomplete
    • Affects Version/s: 5.0 RC3
    • Fix Version/s: 5.0 RC4
    • Component/s: [Build]
    • Labels:
      None
    • Last commented by a User:
      false

      Description

      The sonar build is failing for quite some time. I can reproduce that locally by having Sonar running on my machine + ./gradlew sonarqube

      java.lang.IllegalStateException: Multiple matching methods: ResolvableMethod.Builder[
      	objectClass = org.springframework.web.reactive.result.method.annotation.ResponseBodyResultHandlerTests$TestController,
      	filters = [
      		annotationNotPresent=[interface org.springframework.web.bind.annotation.ResponseBody]
      	]
      ]
      Matched:
      [
      	private static boolean[] org.springframework.web.reactive.result.method.annotation.ResponseBodyResultHandlerTests$TestController.$jacocoInit(),
      	public java.lang.String org.springframework.web.reactive.result.method.annotation.ResponseBodyResultHandlerTests$TestController.doWork()
      ]
      	at org.springframework.util.Assert.state(Assert.java:73)
      	at org.springframework.web.method.ResolvableMethod$Builder.build(ResolvableMethod.java:374)
      	at org.springframework.web.method.ResolvableMethod$Builder.resolveMethod(ResolvableMethod.java:403)
      	at org.springframework.web.reactive.result.method.annotation.ResponseBodyResultHandlerTests.supports(ResponseBodyResultHandlerTests.java:86)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
      	at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
      	at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
      	at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
      	at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:26)
      	at org.junit.runners.ParentRunner.runLeaf(ParentRunner.java:325)
      	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:78)
      	at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:57)
      	at org.junit.runners.ParentRunner$3.run(ParentRunner.java:290)
      

      Looks like Jacoco is messing up something

        Activity

        snicoll Stéphane Nicoll added a comment -

        The build failure is now fixed but we have other issues with sonarqube executing findbugs itself (related to the Gradle upgrade most probably). Let's park this one for now.


          People

          • Assignee:
            snicoll Stéphane Nicoll
            Reporter:
            snicoll Stéphane Nicoll
            Last updater:
            Stéphane Nicoll
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Days since last comment:
              13 weeks, 1 day ago