Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-15976

ChannelRegistration.setInterceptors is misnamed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 4.3.12, 5.0 GA
    • Component/s: Messaging:WebSocket
    • Labels:
      None
    • Last commented by a User:
      true

      Description

      While refactoring the ChannelRegistration code a bit for SPR-15962, I've noticed that ChannelRegistration.setInterceptors is misnamed since it actually adds interceptors to the channel's current list. I've therefore deprecated it in favor of a fluently named interceptors(...) method which is documented to add to the list.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                juergen.hoeller Juergen Hoeller
                Reporter:
                juergen.hoeller Juergen Hoeller
                Last updater:
                Spring Issuemaster
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Days since last comment:
                  27 weeks ago