Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-16405

Upgrade to ASM 6.0 level (for CGLIB 3.2.6)

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: 4.3.13
    • Fix Version/s: 4.3.14
    • Component/s: Core
    • Labels:
      None
    • Last commented by a User:
      true

      Description

      As required by SPR-16267, Spring Framework 4.3.14 needs to be upgraded to CGLIB 3.2.6. Since the latter is based on ASM 6.0 now, we have to upgrade our ASM fork to 6.0 level in the 4.3.x line as well (backported from 5.0).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              juergen.hoeller Juergen Hoeller
              Reporter:
              juergen.hoeller Juergen Hoeller
              Last updater:
              Spring Issues Spring Issues
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 37 weeks ago