Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-17352

Replace context by provider<Foo>() in Kotlin bean DSL

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 5.1.1
    • Component/s: None
    • Labels:
    • Last commented by a User:
      true

      Description

      Spring Framework 5.1.0 exposed by mistake context in the Kotlin bean DSL API in order to fix SPR-16269. Now that BeanFactory#getBeanprovider is available, it should be exposed via a provider<Foo>() function in order to provide a more clean API.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              sdeleuze S├ębastien Deleuze
              Reporter:
              sdeleuze S├ębastien Deleuze
              Last updater:
              Spring Issues Spring Issues
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 23 weeks, 6 days ago