Spring Framework
  1. Spring Framework
  2. SPR-5156

Support use of @Configurable mechanism across multiple OSGi bundles

    Details

    • Type: Improvement Improvement
    • Status: Reopened
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: 2.5.5
    • Fix Version/s: General Backlog
    • Component/s: Core:AOP
    • Labels:
    • Last commented by a User:
      true

      Description

      In OSGI @Configurable mechanism works well only when used in one bundle.
      If there is <context:spring-configured /> in application contexts of more then one bundle, the AnnotationBeanConfigurerAspect (single instance) is injected with two different BeanConfigurerSupport objects in non deterministic order.
      Bundle whose BeanFactory is injected to aspect most recently works well - others don't work at all.

      Is there any work around for this problem?

        Issue Links

          Activity

          Martin Lippert added a comment -

          I think this is a duplicate of 5401

          Wim Deblauwe added a comment -

          We are having the same problem in a plugin mechanism we created ourselves based on Spring. For the moment, we changed our plugins to no longer use @Configurable anymore as a workaround. I would love to see this fixed so we can have the convenience of @Configurable again.

          Wim Deblauwe added a comment -

          Both this issue and SPR-5401 are resolved as duplicate without any fix version. Does this mean that the issue will not be solved at all ?

          Chris Beams added a comment -

          Sorry, that was actually a mistake. I meant to slate one of these issues for a backlog, but ended up resolving them both as duplicates of each other in the end.

          Andreas Höhmann added a comment -

          Any progress in this direction???

          Charlie Mordant added a comment -

          To what I know Spring is not OSGI anymore (in 3.2, Manifests aren't generated anymore).
          You can try Gemini or Aries projects to have DI (PAX-CDI for annotations), and Virgo to have a nice Configurable annotation support.

          It would be nice to have a full Spring support for OSGI out of the box, but for the time I'm following this, my hope is decreasing from day to day...


            People

            • Assignee:
              Unassigned
              Reporter:
              Wojciech Durczyński
              Last updater:
              Charlie Mordant
            • Votes:
              15 Vote for this issue
              Watchers:
              21 Start watching this issue

              Dates

              • Created:
                Updated:
                Days since last comment:
                37 weeks, 1 day ago