Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-7130

oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType' is back

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.0 final
    • Fix Version/s: None
    • Component/s: Core, Web
    • Labels:
      None
    • Last commented by a User:
      false

      Description

      We are currently working on an enterprise project for one of our biggest clients. We are using Spring 2.0 and Spring Web Flow 1.0 Rc4. While deploying the application to Oracle 9ias 10.1.2.0.2 in our development environment, we encountered the following error. We experienced the same error in Spring 2.0 RC2 and it was fixed in Spring 2.0 RC3 by Rick Evans. The ticket No is SPR - 2290. Kindly fix the bug. I will attach the XMLParser Oracle uses so you guys can test it. This is a critical error and we are unable to move forward.

      EXCEPTION FROM THE LOG FILE:
      ------------------------------------------------

      06/10/11 17:58:18 Started
      06/10/11 17:58:21 drlm: jsp: init
      06/10/11 17:58:21 drlm: context: init
      06/10/11 17:58:21 drlm: Loading Spring root WebApplicationContext
      06/10/11 17:58:52 drlm: Error initializing servlet
      org.springframework.beans.factory.BeanDefinitionStoreException: Line 8 in XML document from ServletContext resource [/WEB-INF/drlm-servlet.xml] is invalid; nested exception is oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
      Caused by: oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
      at oracle.xml.parser.v2.XMLError.flushErrorHandler(XMLError.java:444)
      at oracle.xml.parser.v2.XMLError.flushErrors1(XMLError.java:303)
      at oracle.xml.parser.v2.NonValidatingParser.parseDocument(NonValidatingParser.java:290)
      at oracle.xml.parser.v2.XMLParser.parse(XMLParser.java:196)
      at oracle.xml.jaxp.JXDocumentBuilder.parse(JXDocumentBuilder.java:151)
      at org.springframework.beans.factory.xml.DefaultDocumentLoader.loadDocument(DefaultDocumentLoader.java:77)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:405)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:357)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:334)
      at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:126)
      at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:142)
      at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:123)
      at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:91)
      at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:94)
      at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:294)
      at org.springframework.web.context.support.AbstractRefreshableWebApplicationContext.refresh(AbstractRefreshableWebApplicationContext.java:156)
      at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:246)
      at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:184)
      at org.springframework.web.context.ContextLoaderServlet.init(ContextLoaderServlet.java:83)
      at javax.servlet.GenericServlet.init(GenericServlet.java:258)
      at com.evermind.server.http.HttpApplication.loadServlet(HttpApplication.java:2354)
      at com.evermind.server.http.HttpApplication.findServlet(HttpApplication.java:4795)
      at com.evermind.server.http.HttpApplication.initPreloadServlets(HttpApplication.java:4889)
      at com.evermind.server.http.HttpApplication.initDynamic(HttpApplication.java:1015)
      at com.evermind.server.http.HttpApplication.<init>(HttpApplication.java:549)
      at com.evermind.server.Application.getHttpApplication(Application.java:890)
      at com.evermind.server.http.HttpServer.getHttpApplication(HttpServer.java:707)
      at com.evermind.server.http.HttpSite.initApplications(HttpSite.java:625)
      at com.evermind.server.http.HttpSite.setConfig(HttpSite.java:278)
      at com.evermind.server.http.HttpServer.setSites(HttpServer.java:278)
      at com.evermind.server.http.HttpServer.setConfig(HttpServer.java:179)
      at com.evermind.server.ApplicationServer.initializeHttp(ApplicationServer.java:2394)
      at com.evermind.server.ApplicationServer.setConfig(ApplicationServer.java:1551)
      at com.evermind.server.ApplicationServerLauncher.run(ApplicationServerLauncher.java:92)
      at java.lang.Thread.run(Thread.java:534)
      06/10/11 17:58:52 drlm: Error preloading servlet
      javax.servlet.ServletException: Error initializing servlet
      at com.evermind.server.http.HttpApplication.findServlet(HttpApplication.java:4846)
      at com.evermind.server.http.HttpApplication.initPreloadServlets(HttpApplication.java:4889)
      at com.evermind.server.http.HttpApplication.initDynamic(HttpApplication.java:1015)
      at com.evermind.server.http.HttpApplication.<init>(HttpApplication.java:549)
      at com.evermind.server.Application.getHttpApplication(Application.java:890)
      at com.evermind.server.http.HttpServer.getHttpApplication(HttpServer.java:707)
      at com.evermind.server.http.HttpSite.initApplications(HttpSite.java:625)
      at com.evermind.server.http.HttpSite.setConfig(HttpSite.java:278)
      at com.evermind.server.http.HttpServer.setSites(HttpServer.java:278)
      at com.evermind.server.http.HttpServer.setConfig(HttpServer.java:179)
      at com.evermind.server.ApplicationServer.initializeHttp(ApplicationServer.java:2394)
      at com.evermind.server.ApplicationServer.setConfig(ApplicationServer.java:1551)
      at com.evermind.server.ApplicationServerLauncher.run(ApplicationServerLauncher.java:92)
      at java.lang.Thread.run(Thread.java:534)
      06/10/11 17:58:52 drlm: drlm: init
      06/10/11 17:58:52 drlm: Loading WebApplicationContext for Spring FrameworkServlet 'drlm'
      06/10/11 17:58:52 drlm: Error initializing servlet
      org.springframework.beans.factory.BeanDefinitionStoreException: Line 8 in XML document from ServletContext resource [/WEB-INF/drlm-servlet.xml] is invalid; nested exception is oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
      Caused by: oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
      at oracle.xml.parser.v2.XMLError.flushErrorHandler(XMLError.java:444)
      at oracle.xml.parser.v2.XMLError.flushErrors1(XMLError.java:303)
      at oracle.xml.parser.v2.NonValidatingParser.parseDocument(NonValidatingParser.java:290)
      at oracle.xml.parser.v2.XMLParser.parse(XMLParser.java:196)
      at oracle.xml.jaxp.JXDocumentBuilder.parse(JXDocumentBuilder.java:151)
      at org.springframework.beans.factory.xml.DefaultDocumentLoader.loadDocument(DefaultDocumentLoader.java:77)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:405)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:357)
      at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:334)
      at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:126)
      at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:142)
      at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:123)
      at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:91)
      at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:94)
      at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:294)
      at org.springframework.web.context.support.AbstractRefreshableWebApplicationContext.refresh(AbstractRefreshableWebApplicationContext.java:156)
      at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:246)
      at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:184)
      at org.springframework.web.context.ContextLoaderServlet.init(ContextLoaderServlet.java:83)
      at javax.servlet.GenericServlet.init(GenericServlet.java:258)
      at com.evermind.server.http.HttpApplication.loadServlet(HttpApplication.java:2354)
      at com.evermind.server.http.HttpApplication.findServlet(HttpApplication.java:4795)
      at com.evermind.server.http.HttpApplication.initPreloadServlets(HttpApplication.java:4889)
      at com.evermind.server.http.HttpApplication.initDynamic(HttpApplication.java:1015)
      at com.evermind.server.http.HttpApplication.<init>(HttpApplication.java:549)
      at com.evermind.server.Application.getHttpApplication(Application.java:890)
      at com.evermind.server.http.HttpServer.getHttpApplication(HttpServer.java:707)
      at com.evermind.server.http.HttpSite.initApplications(HttpSite.java:625)
      at com.evermind.server.http.HttpSite.setConfig(HttpSite.java:278)
      at com.evermind.server.http.HttpServer.setSites(HttpServer.java:278)
      at com.evermind.server.http.HttpServer.setConfig(HttpServer.java:179)
      at com.evermind.server.ApplicationServer.initializeHttp(ApplicationServer.java:2394)
      at com.evermind.server.ApplicationServer.setConfig(ApplicationServer.java:1551)
      at com.evermind.server.ApplicationServerLauncher.run(ApplicationServerLauncher.java:92)
      at java.lang.Thread.run(Thread.java:534)
      06/10/11 17:58:52 drlm: Error preloading servlet
      javax.servlet.ServletException: Error initializing servlet
      at com.evermind.server.http.HttpApplication.findServlet(HttpApplication.java:4846)
      at com.evermind.server.http.HttpApplication.initPreloadServlets(HttpApplication.java:4889)
      at com.evermind.server.http.HttpApplication.initDynamic(HttpApplication.java:1015)
      at com.evermind.server.http.HttpApplication.<init>(HttpApplication.java:549)
      at com.evermind.server.Application.getHttpApplication(Application.java:890)
      at com.evermind.server.http.HttpServer.getHttpApplication(HttpServer.java:707)
      at com.evermind.server.http.HttpSite.initApplications(HttpSite.java:625)
      at com.evermind.server.http.HttpSite.setConfig(HttpSite.java:278)
      at com.evermind.server.http.HttpServer.setSites(HttpServer.java:278)
      at com.evermind.server.http.HttpServer.setConfig(HttpServer.java:179)
      at com.evermind.server.ApplicationServer.initializeHttp(ApplicationServer.java:2394)
      at com.evermind.server.ApplicationServer.setConfig(ApplicationServer.java:1551)
      at com.evermind.server.ApplicationServerLauncher.run(ApplicationServerLauncher.java:92)
      at java.lang.Thread.run(Thread.java:534)
      06/10/11 17:58:52 drlm: dwr-invoker: init
      06/10/11 17:58:53 drlm: Started

      drlm-servlet.xml file:
      ----------------------------

      <?xml version="1.0" encoding="UTF-8"?>
      <beans xmlns="http://www.springframework.org/schema/beans"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:flow="http://www.springframework.org/schema/webflow-config"
      xsi:schemaLocation="http://www.springframework.org/schema/beans
      http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
      http://www.springframework.org/schema/webflow-config
      http://www.springframework.org/schema/webflow-config/spring-webflow-config-1.0.xsd">
      <!--

      • DispatcherServlet application context for Device Registration and Listing Application web tier.
        -->

      <!-- ========================= MESSAGE SOURCE DEFINITION ========================= -->
      <!--

      • Message source for this context, loaded from localized "messages_xx" files.
      • Could also reside in the root application context, as it is generic,
      • but is currently just used within DRLM's web tier.
        -->
        <bean id="messageSource" class="org.springframework.context.support.ResourceBundleMessageSource">
        <property name="basename" value="messages"/>
        </bean>

      <!--Enabling DWR as a standard controller -->
      <bean id="dwrController" lazy-init="true" class= "org.springframework.web.servlet.mvc.ServletWrappingController">
      <property name="servletClass"><value>uk.ltd.getahead.dwr.DWRServlet</value></property>
      <property name="servletName"><value>dwr-invoker</value></property>
      <property name="initParameters"><props> <prop key="debug">true</prop></props></property>
      </bean>

      <!--
      A general purpose controller for the entire "DRLM" application,
      exposed at the /drlm.htm URL. The id of a flow to launch should be passed
      in using the "_flowId" request parameter: e.g. /drlm.htm?_flowId=new-reg-flow
      -->
      <bean name="flowController" class="org.springframework.webflow.executor.mvc.FlowController">
      <property name="flowExecutor" ref="flowExecutor"/>
      </bean>

      <!-- Url mapping definitions -->
      <bean id="urlMapping" class="org.springframework.web.servlet.handler.SimpleUrlHandlerMapping">
      <property name="order" value="1"/>
      <!-- <property name="interceptors">
      <list>
      <ref bean="signonInterceptor"/>
      </list>
      </property>-->
      <property name="mappings"> <!-- secure mappings require user session -->
      <props>
      <prop key="/drlm.htm">flowController</prop>
      <prop key="/mainMenu.htm">drlmMainMenuController</prop>
      </props>
      </property>
      </bean>

      <bean class="org.springframework.web.servlet.handler.BeanNameUrlHandlerMapping">
      <property name="order" value="2"/>
      </bean>

      <!-- Maps flow view-state view names to JSP templates -->
      <bean id="viewResolver" class="org.springframework.web.servlet.view.InternalResourceViewResolver">
      <property name="prefix" value="/WEB-INF/jsp/"/>
      <property name="suffix" value=".jsp"/>
      </bean>

      <!-- Launches new flow executions and resumes existing executions.
      This executor is configured with a continuation-based repository that
      manages continuation state in the user session. -->
      <flow:executor id="flowExecutor" registry-ref="flowRegistry" repository-type="continuation"/>

      <!-- Creates the registry of flow definitions for this application -->
      <flow:registry id="flowRegistry">
      <flow:location path="file:html/WEB-INF/flows/*/-flow.xml"/>
      </flow:registry>

      <!-- Validator Class for Registration Form -->
      <bean id="registrationFormValidator" class="gov.fda.furls.drlm.web.validator.RegistrationFormValidator"/>

      <!-- FormAction for Registration form -->
      <bean id="registrationAction" class="gov.fda.furls.drlm.web.action.RegistrationAction">
      <property name="validator" ref="registrationFormValidator"/>
      <property name="accountServices" ref="accountServices" />
      <property name="registrationLookUpServices" ref="registrationLookUpServices" />
      </bean>

      <!-- added for controller by Yanqi -->
      <bean id="drlmMainMenuController" class="gov.fda.furls.drlm.web.controller.DRLMMainMenuController">
      </bean>

      </beans>

        Issue Links

          Activity

          gviczai Viczai Gábor added a comment -

          This bug is back in release 3.0.2.RELEASE (2.5.6.SEC01 works fine)

          Environment: OC4J 10.1.3.5 standalone (SUN JDK 1.5)

          OC4J log:

          INFO - Root WebApplicationContext: initialization started
          INFO - Refreshing Root WebApplicationContext: startup date [Sun Apr 25 12:33:01 CEST 2010]; root of context hierarchy
          INFO - Loading XML bean definitions from ServletContext resource [/WEB-INF/classes/applicationContext.xml]

          <Line 43, Column 57>: XML-24509: (Error) Duplicated definition for: 'identifiedType'
          <Line 60, Column 28>: XML-24509: (Error) Duplicated definition for: 'beans'
          <Line 145, Column 34>: XML-24509: (Error) Duplicated definition for: 'description'
          <Line 157, Column 29>: XML-24509: (Error) Duplicated definition for: 'import'
          <Line 179, Column 28>: XML-24509: (Error) Duplicated definition for: 'alias'
          <Line 208, Column 33>: XML-24509: (Error) Duplicated definition for: 'beanElements'
          <Line 222, Column 44>: XML-24509: (Error) Duplicated definition for: 'beanAttributes'
          <Line 487, Column 43>: XML-24509: (Error) Duplicated definition for: 'meta'
          <Line 495, Column 35>: XML-24509: (Error) Duplicated definition for: 'metaType'
          <Line 512, Column 27>: XML-24509: (Error) Duplicated definition for: 'bean'
          <Line 532, Column 38>: XML-24509: (Error) Duplicated definition for: 'constructor-arg'
          <Line 600, Column 51>: XML-24509: (Error) Duplicated definition for: 'property'
          <Line 611, Column 36>: XML-24509: (Error) Duplicated definition for: 'lookup-method'
          <Line 647, Column 38>: XML-24509: (Error) Duplicated definition for: 'replaced-method'
          <Line 684, Column 31>: XML-24509: (Error) Duplicated definition for: 'arg-type'
          <Line 711, Column 26>: XML-24509: (Error) Duplicated definition for: 'ref'
          <Line 749, Column 28>: XML-24509: (Error) Duplicated definition for: 'idref'
          <Line 783, Column 28>: XML-24509: (Error) Duplicated definition for: 'value'
          <Line 811, Column 27>: XML-24509: (Error) Duplicated definition for: 'null'
          <Line 825, Column 39>: XML-24509: (Error) Duplicated definition for: 'collectionElements'
          <Line 842, Column 48>: XML-24509: (Error) Duplicated definition for: 'list'
          <Line 852, Column 47>: XML-24509: (Error) Duplicated definition for: 'set'
          <Line 860, Column 41>: XML-24509: (Error) Duplicated definition for: 'map'
          <Line 868, Column 45>: XML-24509: (Error) Duplicated definition for: 'entry'
          <Line 877, Column 45>: XML-24509: (Error) Duplicated definition for: 'props'
          <Line 886, Column 26>: XML-24509: (Error) Duplicated definition for: 'key'
          <Line 897, Column 27>: XML-24509: (Error) Duplicated definition for: 'prop'
          <Line 916, Column 39>: XML-24509: (Error) Duplicated definition for: 'propertyType'
          <Line 987, Column 40>: XML-24509: (Error) Duplicated definition for: 'listOrSetType'
          <Line 996, Column 34>: XML-24509: (Error) Duplicated definition for: 'mapType'
          <Line 1017, Column 36>: XML-24509: (Error) Duplicated definition for: 'entryType'
          <Line 1056, Column 36>: XML-24509: (Error) Duplicated definition for: 'propsType'
          <Line 1069, Column 45>: XML-24509: (Error) Duplicated definition for: 'defaultable-boolean'
          <Line 17, Column 33>: XML-24509: (Error) Duplicated definition for: 'annotation'
          <Line 35, Column 45>: XML-24509: (Error) Duplicated definition for: 'typedParameterType'
          <Line 39, Column 38>: XML-24509: (Error) Duplicated definition for: 'exportsType'
          ERROR - Context initialization failed
          org.springframework.beans.factory.xml.XmlBeanDefinitionStoreException: Line 15 in XML document from ServletContext resource [/WEB-INF/classes/applicationContext.xml] is invalid; nested exception is oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
          at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:396)
          at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:334)
          at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:302)
          at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:143)
          at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:178)
          at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:149)
          at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:124)
          at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:93)
          at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:130)
          at org.springframework.context.support.AbstractApplicationContext.obtainFreshBeanFactory(AbstractApplicationContext.java:465)
          at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:395)
          at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:276)
          at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:197)
          at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:47)
          at com.evermind.server.http.HttpApplication.initDynamic(HttpApplication.java:1279)
          at com.evermind.server.http.HttpApplication.<init>(HttpApplication.java:848)
          at com.evermind.server.ApplicationStateRunning.getHttpApplication(ApplicationStateRunning.java:435)
          at com.evermind.server.Application.getHttpApplication(Application.java:592)
          at com.evermind.server.http.HttpSite$HttpApplicationRunTimeReference.createHttpApplicationFromReference(HttpSite.java:2280)
          at com.evermind.server.http.HttpSite$HttpApplicationRunTimeReference.<init>(HttpSite.java:2199)
          at com.evermind.server.http.HttpSite.addHttpApplication(HttpSite.java:1833)
          at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(WebApplicationBinder.java:304)
          at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(WebApplicationBinder.java:120)
          at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(WebApplicationBinder.java:92)
          at oracle.oc4j.admin.internal.ApplicationDeployer.bindWebApp(ApplicationDeployer.java:825)
          at oracle.oc4j.admin.internal.ApplicationDeployer.doDeploy(ApplicationDeployer.java:276)
          at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.java:100)
          at oracle.oc4j.admin.jmx.server.mbeans.deploy.OC4JDeployerRunnable.doRun(OC4JDeployerRunnable.java:52)
          at oracle.oc4j.admin.jmx.server.mbeans.deploy.DeployerRunnable.run(DeployerRunnable.java:81)
          at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:298)
          at java.lang.Thread.run(Thread.java:595)
          Caused by: oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
          at oracle.xml.parser.v2.XMLError.flushErrorHandler(XMLError.java:418)
          at oracle.xml.parser.v2.XMLError.flushErrors1(XMLError.java:284)
          at oracle.xml.parser.v2.NonValidatingParser.parseDocument(NonValidatingParser.java:329)
          at oracle.xml.parser.v2.XMLParser.parse(XMLParser.java:213)
          at oracle.xml.jaxp.JXDocumentBuilder.parse(JXDocumentBuilder.java:155)
          at org.springframework.beans.factory.xml.DefaultDocumentLoader.loadDocument(DefaultDocumentLoader.java:75)
          at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:388)
          ... 30 more
          Caused by: oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
          at oracle.xml.parser.schema.XSDBuilder.buildSchema(XSDBuilder.java:856)
          at oracle.xml.parser.schema.XSDBuilder.build(XSDBuilder.java:503)
          at oracle.xml.parser.schema.XSDValidator.processSchemaLocation(XSDValidator.java:980)
          at oracle.xml.parser.schema.XSDValidator.startElement(XSDValidator.java:585)
          at oracle.xml.parser.v2.NonValidatingParser.parseElement(NonValidatingParser.java:1315)
          at oracle.xml.parser.v2.NonValidatingParser.parseRootElement(NonValidatingParser.java:362)
          at oracle.xml.parser.v2.NonValidatingParser.parseDocument(NonValidatingParser.java:308)
          ... 34 more
          10/04/25 12:33:01 SEVERE: ProgressObjectImpl.reportError Line 15 in XML document from ServletContext resource [/WEB-INF/classes/applicationContext.xml] is invalid; nested exception is oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'oracle.oc4j.admin.jmx.shared.exceptions.InternalException: Line 15 in XML document from ServletContext resource [/WEB-INF/classes/applicationContext.xml] is invalid; nested exception is oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
          at oracle.oc4j.admin.jmx.shared.deploy.NotificationUserData.<init>(NotificationUserData.java:107)
          at oracle.oc4j.admin.internal.Notifier.reportError(Notifier.java:429)
          at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.java:130)
          at oracle.oc4j.admin.jmx.server.mbeans.deploy.OC4JDeployerRunnable.doRun(OC4JDeployerRunnable.java:52)
          at oracle.oc4j.admin.jmx.server.mbeans.deploy.DeployerRunnable.run(DeployerRunnable.java:81)
          at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:298)
          at java.lang.Thread.run(Thread.java:595)
          Caused by: oracle.oc4j.admin.internal.DeployerException: Line 15 in XML document from ServletContext resource [/WEB-INF/classes/applicationContext.xml] is invalid; nested exception is oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
          at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:396)
          at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:334)
          at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:302)
          at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:143)
          at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:178)
          at org.springframework.beans.factory.support.AbstractBeanDefinitionReader.loadBeanDefinitions(AbstractBeanDefinitionReader.java:149)
          at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:124)
          at org.springframework.web.context.support.XmlWebApplicationContext.loadBeanDefinitions(XmlWebApplicationContext.java:93)
          at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:130)
          at org.springframework.context.support.AbstractApplicationContext.obtainFreshBeanFactory(AbstractApplicationContext.java:465)
          at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:395)
          at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:276)
          at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:197)
          at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:47)
          at com.evermind.server.http.HttpApplication.initDynamic(HttpApplication.java:1279)
          at com.evermind.server.http.HttpApplication.<init>(HttpApplication.java:848)
          at com.evermind.server.ApplicationStateRunning.getHttpApplication(ApplicationStateRunning.java:435)
          at com.evermind.server.Application.getHttpApplication(Application.java:592)
          at com.evermind.server.http.HttpSite$HttpApplicationRunTimeReference.createHttpApplicationFromReference(HttpSite.java:2280)
          at com.evermind.server.http.HttpSite$HttpApplicationRunTimeReference.<init>(HttpSite.java:2199)
          at com.evermind.server.http.HttpSite.addHttpApplication(HttpSite.java:1833)
          at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(WebApplicationBinder.java:304)
          at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(WebApplicationBinder.java:120)
          at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(WebApplicationBinder.java:92)
          at oracle.oc4j.admin.internal.ApplicationDeployer.bindWebApp(ApplicationDeployer.java:825)
          at oracle.oc4j.admin.internal.ApplicationDeployer.doDeploy(ApplicationDeployer.java:276)
          at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.java:100)
          ... 4 more

          10/04/25 12:33:11 WARNING: DeployerRunnable.run Line 15 in XML document from ServletContext resource [/WEB-INF/classes/applicationContext.xml] is invalid; nested exception is oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'oracle.oc4j.admin.internal.DeployerException: Line 15 in XML document from ServletContext resource [/WEB-INF/classes/applicationContext.xml] is invalid; nested exception is oracle.xml.parser.schema.XSDException: Duplicated definition for: 'identifiedType'
          at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.java:133)
          at oracle.oc4j.admin.jmx.server.mbeans.deploy.OC4JDeployerRunnable.doRun(OC4JDeployerRunnable.java:52)
          at oracle.oc4j.admin.jmx.server.mbeans.deploy.DeployerRunnable.run(DeployerRunnable.java:81)
          at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:298)
          at java.lang.Thread.run(Thread.java:595)

          applicationcontext.xml:

          <?xml version="1.0" encoding="UTF-8"?>
          <beans xmlns="http://www.springframework.org/schema/beans"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xmlns:context="http://www.springframework.org/schema/context"
          xmlns:tx="http://www.springframework.org/schema/tx"
          xmlns:aop="http://www.springframework.org/schema/aop"
          xmlns:security="http://www.springframework.org/schema/security"
          xmlns:webflow="http://www.springframework.org/schema/webflow-config"
          xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-3.0.xsd
          http://www.springframework.org/schema/context http://www.springframework.org/schema/context/spring-context-3.0.xsd
          http://www.springframework.org/schema/tx http://www.springframework.org/schema/tx/spring-tx-3.0.xsd
          http://www.springframework.org/schema/aop http://www.springframework.org/schema/aop/spring-aop-3.0.xsd
          http://www.springframework.org/schema/security http://www.springframework.org/schema/security/spring-security-2.0.4.xsd
          http://www.springframework.org/schema/webflow-config http://www.springframework.org/schema/webflow-config/spring-webflow-config-2.0.xsd"
          default-autowire="byName">
          ...

          patrick.crocker@gmail.com Patrick Crocker added a comment -

          This issue also occurs with Spring 3.0.1.RELEASE-A.

          jmiazga Jason Miazga added a comment -

          This issue also occurs in Spring 3.0.3

          toolsrme101 David Reed added a comment -

          This also occurs in Spring 3.0.4

          olaguibert Carlos Olaguibert added a comment -

          Hola, saludos.
          Creo que este problema no es un Bug como tal, si solo se presenta en Oracle Application Server.

          Yo he tenido el mismo problema en un par de ocaciones y lo que necesitas hacer es decirle al servidor OAS que cargue primero las librerias del servidor y en segunda instancia las del proyecto.

          A mi me ha funcionado.

          Intento de traducción / Attempt to translation.

          Hello, Greetings. I think this problem is not a bug as such, if only available in Oracle Application Server. I have had the same problem a couple of occasions and you need to do is tell the server to load first the OAS server libraries and secondly the project. I really worked.

          jurkens Jean Pierre Urkens added a comment -

          I'm having this same problem.
          I'm using oracle libraries to manipulate XML in the database and thus intensively uses oracle specific classes in my application (i.e. XMLType,XMLDocument,...).
          We need to migrate from oracle10g to oracle11g and I therefore upgraded the libs to oracle11g version (more specifically xmlparserv2.jar that comes with Oracle's .XDK version_11.2.0.1.0). After having included this library on the classpath the Spring application context file referencing the spring schemes doesn't load any longer.

          Can anyone inform me how to resolve this problem?

          dairemac Daire Mac Mathúna added a comment -

          Same problem. Spring 3.1.1.

          weisband Igor Weisband added a comment -

          You are using the buggy parser. Please define in the Eclipse Window->Preferences->Tomcat->JVM settings:

          -Djavax.xml.parsers.SAXParserFactory=com.sun.org.apache.xerces.internal.jaxp.SAXParserFactoryImpl
          -Djavax.xml.parsers.DocumentBuilderFactory=com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl

          Or it must be defined in the VM-Parameters of your Run-Configuration if you use the main()-method.

          juergen.hoeller Juergen Hoeller added a comment -

          Closing groups of outdated issues. Please reopen if still relevant.


            People

            • Assignee:
              juergen.hoeller Juergen Hoeller
              Reporter:
              gviczai Viczai Gábor
              Last updater:
              Juergen Hoeller
            • Votes:
              9 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                2 years, 22 weeks, 4 days ago