Thanks all for pointing this out. Yes, obviously it should be dot notation.
I've updated to:
While it may be the most 'correct' approach to fully qualify here with org.springframework.profile, I'm currently thinking that saving keystrokes is worth the tradeoff. A naming collision with spring.profile.* is highly unlikely anyway.
Currently, there may be only one default profile, but any number of active profiles may be specified. For this reason, it may be best to use a plural 'profiles' (spring.profiles.active), but (a) I dislike the asymmetry with spring.profile.default remaining singular - this makes things harder to remember and errors are more likely. (b) it's conceivable that we would allow for multiple default profiles in the future, so wouldn't want to be stuck with the singular naming. I see the choices as being:
Generally speaking, we use singular package names (.beans being a notable exception). This is enough to sway me into saying we should leave profile singular (as is now the case in my latest commit).