Spring Framework
  1. Spring Framework
  2. SPR-8175

ExtendedBeanInfo Passes Empty Property Name to PropertyDescriptor Causing IntrospectionException: bad property name

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.1 M2
    • Component/s: Core
    • Labels:
      None

      Description

      When handling an ArrayList, the ExtendedBeanInfo Passes Emtpy Property Name to PropertyDescriptor Causing IntrospectionException: bad property name. This occurs in the latest development build of trunk and can be seen in the Greenhouse application. I have attached a patch that provides a junit and a fix.

        Issue Links

          Activity

          Chris Beams added a comment -

          Patch applied - thanks Rob!

          Chris Beams added a comment -

          A general note to watchers of ExtendedBeanInfo-related issues: SPR-10029 is a major refactoring of ExtendedBeanInfo and overall support for non-void returning setter methods.

          If you have submitted a reproduction project with this issue, we have run it through its paces against these new changes, but we would like to ask you to do the same against your actual applications.

          Please consider updating your dev or test builds to work against 3.1.4.BUILD-SNAPSHOT and/or 3.2.0.BUILD-SNAPSHOT to verify, and we would appreciate any feedback, even if it's to let us know that all is well. So that we can consolidate feedback, please add your comments to SPR-10029, and mention the original issue(s) that you were watching.

          Thanks!

          Note also that testing against 3.1.4 is preferable to 3.2.0 because ExtendedBeanInfo is always in the code path in the latter, while in 3.2.0 we've optimized things such that ExtendedBeanInfo is only in play for bean classes that have one or more non-void returning setter methods.


            People

            • Assignee:
              Chris Beams
              Reporter:
              Rob Winch
              Last updater:
              Chris Beams
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                1 year, 21 weeks, 4 days ago