Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-8581

Spring should support Quartz 2.0 CronTrigger interface

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 3.1 M2
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
    • Last commented by a User:
      true

      Description

      CronTriggerBean extends CronTrigger - this causes an IncompatibleClassChangeError with quartz 2.0.2 on the classpath, because CronTrigger is an interface in quartz 2.

      Quartz 2 being around for a couple of months now, it will be good to upgrade spring to support it.

      Note that this issue is not manifested in Tomcat 6 - only in Tomcat 7 (but it is missing in the version drop-down). I believe this is a classloader change, so I'm also reporting an issue to Tomcat. (We are not using this particular class, but tomcat still loads it).

        Issue Links

          Activity

          juergen.hoeller Juergen Hoeller added a comment - - edited

          I'm closing this as "Won't Fix" from the perspective of CronTriggerBean since we have no intention to ever upgrade that class to Quartz 2.0. Note that the rest of Spring's Quartz support is Quartz 2.0 compatible now, as of Spring 3.1 RC1 (see SPR-8359). We're just keeping CronTriggerBean and co for our ongoing compatibility with Quartz 1.x.

          Tomcat really shouldn't be loading classes that the application isn't using. We're relying on that in quite a few places. So if you're not actually using CronTriggerBean, I'd definitely consider this a problem in Tomcat.

          Juergen

          bozho Bozhidar Bozhanov added a comment -

          Agreed. In fact the issue went away and I can't reproduce it anymore, so it's not even Tomcat's problem, but perhaps some weird combination of tomcat + eclipse WTP + java7 "mishap". Sorry for hastily reporting it here.

          momega Martin Vanek added a comment -

          I have had the similar issue, but after installing Tomcat 7.0.25 this annoying issue vanished.

          I guess that this issue is also related to SPR-8945 and more https://issues.apache.org/bugzilla/show_bug.cgi?id=52326.


            People

            • Assignee:
              juergen.hoeller Juergen Hoeller
              Reporter:
              bozho Bozhidar Bozhanov
              Last updater:
              Trevor Marshall
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 40 weeks, 1 day ago