Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-8680

AbstractSingletonProxyFactoryBean is deprecated

    Details

    • Type: Refactoring
    • Status: Resolved
    • Priority: Minor
    • Resolution: Works as Designed
    • Affects Version/s: 3.1 M2
    • Fix Version/s: None
    • Component/s: Core:AOP
    • Labels:
      None
    • Last commented by a User:
      true

      Description

      According to the javadocs of the AbstractSingletonProxyFactoryBean it has been deprecated

      • @deprecated as of Spring 3.1 following the deprecation of its only implementation
      • ( [email protected] [email protected]ryBean * TransactionProxyFactoryBean}

        ) and generally in favor of providing such functionality

      • via Spring XML namespaces, e.g. [email protected] tx:}

        or

        [email protected] @Enable}

        * annotations, e.g.

      • [email protected] @EnableTransactionManagement}

        .

      However there is another implementation CacheProxyFactoryBean which uses this bean. So not sure if either the javadoc is valid or the deprecation at all...

        Issue Links

          Activity

          cbeams Chris Beams added a comment -

          Hi Marten,

          Actually this is as designed and CachProxyFactoryBean is expected to be eliminated entirely. Thanks for the reminder, though; I've just created SPR-8685 to track the original deprecations and to remind Costin to remove CacheProxyFactoryBean if he sees fit.

          Regards,

          Chris

          cbeams Chris Beams added a comment -

          Note that this deprecation has been reverted. See SPR-8685.


            People

            • Assignee:
              cbeams Chris Beams
              Reporter:
              mdeinum Marten Deinum
              Last updater:
              Trevor Marshall
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                5 years, 41 weeks, 6 days ago