Uploaded image for project: 'Spring Framework'
  1. Spring Framework
  2. SPR-8785

Deadlock during application context creation

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 3.0.6
    • Fix Version/s: None
    • Component/s: Core
    • Labels:

      Description

      We face a deadlock in virgo 3.0.0.RELEASE when starting our spring dm powered bundles during the creation of the application contexts. Two bundles get in a deadlock while their contexts get created simultaneously.

      Please see the discussion in the eclipse forum for full stacktraces of the blocking threads.

        Issue Links

          Activity

          ractive Jean-Pierre Bergamin added a comment -

          This issue may be related to SPR-8471

          cbeams Chris Beams added a comment -

          Resolving as duplicate of SPR-8471


            People

            • Assignee:
              juergen.hoeller Juergen Hoeller
              Reporter:
              ractive Jean-Pierre Bergamin
              Last updater:
              Trevor Marshall
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Days since last comment:
                3 years, 25 weeks, 3 days ago