The ObjectsDtd class is inappropriately named... it has a number of constants used by the XML parser to describe the elements and attributes of the XML object definition schema. It has zippo to do with a DTD.
Since we no longer use a DTD, but rather XML Schema, this class might be better off named ObjectSchemaConstants, or (better) something that is not tied to the validation mechanism (in the case that we should ever move to something else).
How about... ObjectDefinitionConstants? ObjectXmlConstants?
Votes and suggestions please.