Classes that use regular expressions are inconsistently named throughout the framework.
For example, we have SdkRegexpMethodPointcut, RegexCriteria, and RegExValidator.
The fix is to pick one of the formats from above and apply it consistently throughout the framework.
I vote for 'RegularExpression', i.e. get rid of the abbreviation and have class names like RegularExpressionMethodPointcut, RegularExpressionCriteria, and RegularExpressionValidator.