Uploaded image for project: 'Spring.NET'
  1. Spring.NET
  2. SPRNET-586

Change name of IRowMapper's method argument IDataReader from 'dataReader' to 'reader'

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.1 M1
    • Fix Version/s: 1.1 M2
    • Component/s: Spring-NET-DA
    • Labels:
      None

      Description

      currently

      public interface IRowMapper
      {
      object MapRow(IDataReader dataReader, int rowNum);
      }
      public interface IResultSetExtractor
      {
      object ExtractData(IDataReader reader);
      }

      change IRowMapper to be

      public interface IRowMapper
      {
      object MapRow(IDataReader reader, int rowNum);
      }

      so that one can more easily cut-n-paste of the implementation of an IResultSetExtractor in an IRowMapper and vice-versa

        Attachments

          Activity

            People

            Assignee:
            mark.pollack Mark Pollack
            Reporter:
            mark.pollack Mark Pollack
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: