Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-102

Eclipse wont start-up raising AssertionFailedException: null argument

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1.0.M1
    • Fix Version/s: 2.1.0.M2
    • Component/s: UI
    • Labels:
    • Environment:
      GNU/Linux 2.6.28-12-generic #43-Ubuntu SMP, Java(TM) SE Runtime Environment (build 1.6.0_13-b03)

      Description

      After selecting the workspace Eclipse shortly loads some plugins and then raises an error:

      !ENTRY org.eclipse.wst.server.core 4 0 2009-05-15 14:36:16.964
      !MESSAGE Error during shutdown
      !STACK 0
      org.eclipse.core.runtime.AssertionFailedException: null argument:
      at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:86)
      at org.eclipse.core.runtime.Assert.isNotNull(Assert.java:74)
      at org.eclipse.core.internal.events.ResourceChangeListenerList.remove(ResourceChangeListenerList.java:146

      1. .log
        30 kB
        Christian Dähn

        Activity

        Hide
        cda Christian Dähn added a comment -

        Attached workspace logfile

        Show
        cda Christian Dähn added a comment - Attached workspace logfile
        Hide
        cdupuis Christian Dupuis added a comment -

        Chrisitian,

        there is this problem in your log:

        !ENTRY org.eclipse.osgi 4 0 2009-05-15 14:36:16.051
        !MESSAGE Application error
        !STACK 1
        org.eclipse.swt.SWTError: XPCOM error -2147467262
        	at org.eclipse.swt.browser.Mozilla.error(Mozilla.java:1638)
        	at org.eclipse.swt.browser.Mozilla.setText(Mozilla.java:1861)
        	at org.eclipse.swt.browser.Browser.setText(Browser.java:737)

        Please follow the instructions on http://dev.eclipse.org/newslists/news.eclipse.tools.jdt/msg23483.html as this is a known problem of eclipse on certain linux distributions.

        Let me know if that solves your problem.

        Christian

        Show
        cdupuis Christian Dupuis added a comment - Chrisitian, there is this problem in your log: !ENTRY org.eclipse.osgi 4 0 2009-05-15 14:36:16.051 !MESSAGE Application error !STACK 1 org.eclipse.swt.SWTError: XPCOM error -2147467262 at org.eclipse.swt.browser.Mozilla.error(Mozilla.java:1638) at org.eclipse.swt.browser.Mozilla.setText(Mozilla.java:1861) at org.eclipse.swt.browser.Browser.setText(Browser.java:737) Please follow the instructions on http://dev.eclipse.org/newslists/news.eclipse.tools.jdt/msg23483.html as this is a known problem of eclipse on certain linux distributions. Let me know if that solves your problem. Christian
        Hide
        cda Christian Dähn added a comment -

        Thanks, Christian. That solved my problem.

        Show
        cda Christian Dähn added a comment - Thanks, Christian. That solved my problem.
        Hide
        cdupuis Christian Dupuis added a comment -

        As per Christian's comment this is solved.

        Show
        cdupuis Christian Dupuis added a comment - As per Christian's comment this is solved.

          People

          • Assignee:
            Unassigned
            Reporter:
            cda Christian Dähn
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: