Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-1211

STS picks the "wrong" path for sources of the grails dependency jars when using symbolic links for GRAILS_HOME

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.5.0.M3
    • Fix Version/s: 2.5.0.RC1
    • Component/s: GRAILS
    • Labels:
      None
    • Environment:
      grails 1.3.4, sts 2.5.0M3 (nightly), ubuntu 10.04, jvm 1.6.20

      Description

      When referencing to the Grails distribution by a symbolic link and using this as GRAILS_HOME in STS - sources ain't displayed correctly.
      When trying to look into a class of grails dependency jar it usually comes up with "Change Attached Source".

        Activity

        aeisenberg Andrew Eisenberg added a comment -

        On a mac, I can't even create an Grails install with a symbolic link. Eclipse crashes on me. Grrrr...

        I'm exploring this further.

        aeisenberg Andrew Eisenberg added a comment -

        When I force STS to use a symbolic link for GRAILS_HOME, I cannot reproduce your problem. This may be a Linux-only issue. I'll reassign to our Ubuntu user.

        aeisenberg Andrew Eisenberg added a comment -

        And I can no longer reproduce the crash that I was experiencing before.

        kdvolder Kris De Volder added a comment - - edited

        I tried to reproduce the problem but couldn't. As far as I can tell when I configure a grails install via sybmolic link, it works completely transparantly.

        Here's what I did.

        • create a folder called 'linked' (from a terminal window in the os)
        • in this folder:
          ln -s <some-other-folder-with-a-bunch-of-grails-versions>/grails-1.3.4

        This creates a link from linked/grails-1.3.4 to where the real grails-1.3.4 install lives.

        I then opened the Grails preferences page, removed all grails installs I had there and added a new one, pointing it to linked/grails-1.3.4

        I then created a new grails project for testing and looked inside its Grails Dependencies class path container.

        I see that a jar like 'grails-core.jar' has attached source and when I click on a .class file in the .jar it indeed opens the correct source file.

        I also see that a lot of other jars do not have source attachements(jars like 'org.springframework...').

        This seems to be the exact same behavior I'm getting when I configured the grails install in a 'non-linked' fashion.

        Konstantinos, are the steps described above similar to what you did to get the problem? If not, could you try to give a more detailed description of the steps needed to produce the erroneous behavior and precisely what goes wrong?

        I'm certainly willing to give it another shot to try determine what the problem is and try to fix it.

        Kris

        kdvolder Kris De Volder added a comment -

        I'm closing this. It seems to work as expected for me and I haven't seen any new information in a few days.

        However, if you have find that the problem still persists for you, please feel free to reopen the issue.


          People

          • Assignee:
            Unassigned
            Reporter:
            kosta Konstantinos Kostarellis
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: