Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-1243

enum in Groovy Script is treated as error

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.1.0.RC1
    • Fix Version/s: 2.5.0.RC1
    • Component/s: GRAILS
    • Labels:
      None
    • Environment:
      STS 2.5.0M3 (Version: 2.5.0.CI-R5736-B89 / Build Id: 201009210809), groovy 1.7.3, jvm 1.6.20, kubuntu 10.04

      Description

      using an enum in a Groovy Script lets STS complain about errors in the Script.

      ------------
      Multiple markers at this line

      • Groovy:Can't have an abstract method in a non-abstract class. The class 'Day' must be declared abstract or the method 'int compareTo(java.io.File)' must be implemented.
      • Groovy:Can't have an abstract method in a non-abstract class. The class 'Day' must be declared abstract or the method 'int compareTo(java.lang.Integer)' must be
        implemented.
      • Groovy:Can't have an abstract method in a non-abstract class. The class 'Day' must be declared abstract or the method 'int compareTo(java.lang.String)' must be
        implemented.
        -------------

      Attached an example Script from http://groovy.codehaus.org/Using+Enums

      1. TryMe.groovy
        0.7 kB
        Konstantinos Kostarellis

        Activity

        aeisenberg Andrew Eisenberg added a comment -

        Hmmm...I am not able to reproduce this on my machine using STS 250M3 or the latest nightly. Please make sure that you are running the latest nightly version of Groovy-Eclipse.

        If this still doesn't help, then can you attach the entire project? Perhaps there is a project specific setting that is breaking things. Before you send the project, be sure to check Project Properties -> Java Build Path -> Enable Project Specific Settings, so I can reproduce your compilation options precisely.

        kosta Konstantinos Kostarellis added a comment -

        I wasn't able to reproduce the faulty behavior on my box any longer (I'm using nightly builds - on Linux). At the time I filed this issue, i was able to reproduce it on my box, too.
        The problem first appeared on the computer of a colleague (Windows). Unfortunately he is ill, since a few days ...
        I'll try to investigate again on this "problem" and report.

        But for the moment i think we can close the issue.
        We can still re-open if it reappears.

        kosta Konstantinos Kostarellis added a comment -

        Problem is gone ... can't reproduce


          People

          • Assignee:
            Unassigned
            Reporter:
            kosta Konstantinos Kostarellis
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: