Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-1245

generate-all grails command in STS 2.5.0.M3 not working with wildcards

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.0.M3
    • Fix Version/s: 2.5.0.RC1
    • Component/s: GRAILS
    • Labels:
      None
    • Environment:
      - STS 2.5.0.M3
      - Mac OS X 10.6.4
      - JDK 1.6.0_20
      - Grails 1.3.4

      Description

      According to grails docs you can pass a wildcard to generate-all command.

      I can run this from cmd line. e.g:
      > grails generate-all "*" //note the wildcard is in quotes to avoid shell gobbling

      However I can't seem to run this in STS. When I do nothing happens on the console.

        Activity

        cdupuis Christian Dupuis added a comment -

        Kris, please take a look at this.

        Christian

        kdvolder Kris De Volder added a comment -

        Hi Numan,

        I think I already fixed this issue, which is a duplicate of this one:

        https://issuetracker.springsource.com/browse/STS-1208

        It is a problem with certain characters getting included in the name of generated launch configurations to launch grails commands.

        However, it is possible that more clones of the bug are lying in wait, since the code involved in launching commands appears to have been copied in a number of places and I just spotted one other place where the proper sanitation procedure had not been applied for the launchconfig name. (And of course I will fix that .

        Assuming you ran it via the grails command popup, I think it should already have been fixed (If you could please try out the latest snapshot from the update site and confirm this)

        http://dist.springsource.com/snapshot/TOOLS/nightly/e3.6/

        However if you still have issues, I'll need some more info from you on precisely how you ran the command (as I said, we seem to have some copies of the code in question that are used under different circumstances, so I need precise details to reproduce).

        I'll leave this issue open for a bit longer until I hear back from you.

        Kris

        kdvolder Kris De Volder added a comment -

        I'm closing the issue. Please feel free to reopen it if you still have problems with this in the latest snapshot build.


          People

          • Assignee:
            Unassigned
            Reporter:
            zenmonkey numan salati
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: