Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-1256

STS Error: Internal Error when trying to copy and paste a Grails Controller

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 2.5.0.M3
    • Fix Version/s: 2.5.0.RC1
    • Component/s: None
    • Labels:
      None

      Description

      While trying to copy and paste a controller I get the following error in STS (Eclipse).

      eclipse.buildId=2.5.0.201008251000-M3
      java.version=1.5.0_22
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
      Framework arguments: -product com.springsource.sts.ide
      Command-line arguments: -os win32 -ws win32 -arch x86_64 -product com.springsource.sts.ide

      Error
      Sun Sep 26 20:59:10 EDT 2010
      Internal Error

      java.lang.reflect.InvocationTargetException
      at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:479)
      at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372)
      at org.eclipse.jface.window.ApplicationWindow$1.run(ApplicationWindow.java:759)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
      at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWindow.java:756)
      at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:2600)
      at org.eclipse.jdt.internal.ui.refactoring.RefactoringExecutionHelper.perform(RefactoringExecutionHelper.java:191)
      at org.eclipse.jdt.internal.ui.refactoring.RefactoringExecutionHelper.perform(RefactoringExecutionHelper.java:151)
      at org.eclipse.jdt.internal.ui.refactoring.reorg.ReorgCopyStarter.run(ReorgCopyStarter.java:68)
      at org.eclipse.jdt.internal.ui.refactoring.reorg.PasteAction$JavaElementAndResourcePaster.paste(PasteAction.java:1314)
      at org.eclipse.jdt.internal.ui.refactoring.reorg.PasteAction.run(PasteAction.java:270)
      at org.eclipse.jdt.ui.actions.SelectionDispatchAction.dispatchRun(SelectionDispatchAction.java:274)
      at org.eclipse.jdt.ui.actions.SelectionDispatchAction.run(SelectionDispatchAction.java:250)
      at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
      at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
      at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4066)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3657)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2629)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2593)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2427)
      at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:670)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:663)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:592)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1383)
      Caused by: java.lang.NoClassDefFoundError: org/hibernate/Session
      at java.lang.Class.getDeclaredFields0(Native Method)
      at java.lang.Class.privateGetDeclaredFields(Class.java:2259)
      at java.lang.Class.getDeclaredFields(Class.java:1715)
      at org.codehaus.groovy.vmplugin.v5.Java5.configureClassNode(Java5.java:341)
      at org.codehaus.groovy.ast.ClassNode.lazyClassInit(ClassNode.java:307)
      at org.codehaus.groovy.ast.ClassNode.getAnnotations(ClassNode.java:1402)
      at org.codehaus.groovy.eclipse.core.inference.BuiltInASTTransform$SingletonASTTransform.create(BuiltInASTTransform.java:56)
      at org.codehaus.groovy.eclipse.core.inference.BuiltInASTTransform.createAll(BuiltInASTTransform.java:205)
      at org.codehaus.groovy.eclipse.core.inference.StandardASTTransformInference.lookupTypeAndDeclaration(StandardASTTransformInference.java:52)
      at org.eclipse.jdt.groovy.search.AbstractSimplifiedTypeLookup.lookupType(AbstractSimplifiedTypeLookup.java:51)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.handleExpression(TypeInferencingVisitorWithRequestor.java:682)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitConstantExpression(TypeInferencingVisitorWithRequestor.java:1045)
      at org.codehaus.groovy.ast.expr.ConstantExpression.visit(ConstantExpression.java:55)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitMethodCallExpression(TypeInferencingVisitorWithRequestor.java:1113)
      at org.codehaus.groovy.ast.expr.MethodCallExpression.visit(MethodCallExpression.java:72)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitBinaryExpression(TypeInferencingVisitorWithRequestor.java:825)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitDeclarationExpression(TypeInferencingVisitorWithRequestor.java:1063)
      at org.codehaus.groovy.ast.expr.DeclarationExpression.visit(DeclarationExpression.java:53)
      at org.codehaus.groovy.ast.CodeVisitorSupport.visitExpressionStatement(CodeVisitorSupport.java:69)
      at org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitExpressionStatement(ClassCodeVisitorSupport.java:209)
      at org.codehaus.groovy.ast.stmt.ExpressionStatement.visit(ExpressionStatement.java:40)
      at org.codehaus.groovy.ast.CodeVisitorSupport.visitBlockStatement(CodeVisitorSupport.java:35)
      at org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitBlockStatement(ClassCodeVisitorSupport.java:179)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitBlockStatement(TypeInferencingVisitorWithRequestor.java:914)
      at org.codehaus.groovy.ast.stmt.BlockStatement.visit(BlockStatement.java:51)
      at org.codehaus.groovy.ast.CodeVisitorSupport.visitClosureExpression(CodeVisitorSupport.java:174)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitClosureExpression(TypeInferencingVisitorWithRequestor.java:904)
      at org.codehaus.groovy.ast.expr.ClosureExpression.visit(ClosureExpression.java:46)
      at org.codehaus.groovy.ast.ClassCodeVisitorSupport.visitField(ClassCodeVisitorSupport.java:130)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitField(TypeInferencingVisitorWithRequestor.java:485)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitJDT(TypeInferencingVisitorWithRequestor.java:331)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitJDT(TypeInferencingVisitorWithRequestor.java:233)
      at org.eclipse.jdt.groovy.search.TypeInferencingVisitorWithRequestor.visitCompilationUnit(TypeInferencingVisitorWithRequestor.java:183)
      at org.codehaus.jdt.groovy.integration.internal.GroovyLanguageSupport.maybePerformDelegatedSearch(GroovyLanguageSupport.java:161)
      at org.codehaus.jdt.groovy.integration.LanguageSupportFactory.maybePerformDelegatedSearch(LanguageSupportFactory.java:88)
      at org.eclipse.jdt.internal.core.search.matching.MatchLocator.locateMatches(MatchLocator.java:1095)
      at org.eclipse.jdt.internal.core.search.matching.MatchLocator.locateMatches(MatchLocator.java:1223)
      at org.eclipse.jdt.internal.core.search.matching.MatchLocator.locateMatches(MatchLocator.java:1355)
      at org.eclipse.jdt.internal.core.search.JavaSearchParticipant.locateMatches(JavaSearchParticipant.java:94)
      at org.eclipse.jdt.internal.core.search.BasicSearchEngine.findMatches(BasicSearchEngine.java:231)
      at org.eclipse.jdt.internal.core.search.BasicSearchEngine.search(BasicSearchEngine.java:515)
      at org.eclipse.jdt.core.search.SearchEngine.search(SearchEngine.java:582)
      at org.eclipse.jdt.internal.corext.refactoring.RefactoringSearchEngine2.searchPattern(RefactoringSearchEngine2.java:484)
      at org.eclipse.jdt.internal.corext.refactoring.reorg.CreateCopyOfCompilationUnitChange.getReferences(CreateCopyOfCompilationUnitChange.java:122)
      at org.eclipse.jdt.internal.corext.refactoring.reorg.CreateCopyOfCompilationUnitChange.createChangeManager(CreateCopyOfCompilationUnitChange.java:61)
      at org.eclipse.jdt.internal.corext.refactoring.reorg.CreateCopyOfCompilationUnitChange.getCopiedFileSource(CreateCopyOfCompilationUnitChange.java:92)
      at org.eclipse.jdt.internal.corext.refactoring.reorg.CreateCopyOfCompilationUnitChange.getOldFile(CreateCopyOfCompilationUnitChange.java:159)
      at org.eclipse.jdt.internal.corext.refactoring.nls.changes.CreateFileChange.perform(CreateFileChange.java:150)
      at org.eclipse.jdt.internal.corext.refactoring.reorg.CreateCopyOfCompilationUnitChange.perform(CreateCopyOfCompilationUnitChange.java:183)
      at org.eclipse.ltk.core.refactoring.CompositeChange.perform(CompositeChange.java:278)
      at org.eclipse.jdt.internal.corext.refactoring.changes.DynamicValidationStateChange.access$0(DynamicValidationStateChange.java:1)
      at org.eclipse.jdt.internal.corext.refactoring.changes.DynamicValidationStateChange$1.run(DynamicValidationStateChange.java:98)
      at org.eclipse.jdt.internal.core.BatchOperation.executeOperation(BatchOperation.java:39)
      at org.eclipse.jdt.internal.core.JavaModelOperation.run(JavaModelOperation.java:728)
      at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1975)
      at org.eclipse.jdt.core.JavaCore.run(JavaCore.java:4777)
      at org.eclipse.jdt.internal.corext.refactoring.changes.DynamicValidationStateChange.perform(DynamicValidationStateChange.java:101)
      at org.eclipse.jdt.internal.corext.refactoring.reorg.JavaCopyProcessor$1.perform(JavaCopyProcessor.java:112)
      at org.eclipse.ltk.core.refactoring.CompositeChange.perform(CompositeChange.java:278)
      at org.eclipse.ltk.core.refactoring.PerformChangeOperation$1.run(PerformChangeOperation.java:258)
      at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1975)
      at org.eclipse.ltk.core.refactoring.PerformChangeOperation.executeChange(PerformChangeOperation.java:306)
      at org.eclipse.ltk.core.refactoring.PerformChangeOperation.run(PerformChangeOperation.java:223)
      at org.eclipse.jdt.internal.ui.refactoring.RefactoringExecutionHelper$Operation.run(RefactoringExecutionHelper.java:106)
      at org.eclipse.jdt.internal.core.BatchOperation.executeOperation(BatchOperation.java:39)
      at org.eclipse.jdt.internal.core.JavaModelOperation.run(JavaModelOperation.java:728)
      at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1975)
      at org.eclipse.jdt.core.JavaCore.run(JavaCore.java:4777)
      at org.eclipse.jdt.internal.ui.actions.WorkbenchRunnableAdapter.run(WorkbenchRunnableAdapter.java:106)
      at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464)
      ... 41 more

        Activity

        aeisenberg Andrew Eisenberg added a comment -

        This appears to be a duplicate of STS-1255.


          People

          • Assignee:
            Unassigned
            Reporter:
            hzaccak Henry Zaccak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: