Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-1262

Grails plugin source files not being picked up on classpath

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Complete
    • Affects Version/s: 2.5.0.M3
    • Fix Version/s: 2.5.0.RC1
    • Component/s: GRAILS
    • Labels:
      None
    • Environment:
      CI-R5877-B102 of the Grails STS feature

      Description

      I'm using a nightly snapshot and now source files in installed plugins are not being picked up on the class path. For example, I have Feeds 1.5 installed into a project and in my project I have the code

      def fb = new feedsplugin.FeedBuilder()

      The above line has an error marker because STS can't find the FeedBuilder class, which is lurking in the src/groovy directory of the Feeds plugin.

        Activity

        pledbrook Peter Ledbrook added a comment -

        I how do I get a stack trace? I didn't see one when I opened the details of the error.

        aeisenberg Andrew Eisenberg added a comment -

        All right. Thanks for the further comments. I now see what is wrong.

        Grails tooling inside of STS supplies a build listener, DependencyExtractingBuildListener, for call back information about Grails build settings. This build listener is passed into a running grails instance. And so, the sts grails core plugin has some compile time dependencies on grails itself.

        However, since the sts grails tooling does not depend on a particular grails version (to remain version neutral), we cannot have any runtime dependencies on grails.

        The problem is with this latest refactoring, we have included some runtime dependencies on grails, which need to be removed.

        aeisenberg Andrew Eisenberg added a comment -

        I have a fix committed for this. I'll have to wait until tomorrow to try it out to see if it is actually working.

        aeisenberg Andrew Eisenberg added a comment -

        Fixed. I tested the latest nightly in a separate STS install and it is working as expected.

        pledbrook Peter Ledbrook added a comment -

        All is good in the world again - thanks!


          People

          • Assignee:
            Unassigned
            Reporter:
            pledbrook Peter Ledbrook
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: