Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-1268

Code completion for bean definitions in Maven projects broken

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.3.2.RELEASE
    • Fix Version/s: 2.5.0.RC1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Tested on Snow Leopard, Windows Vista, Windows 7

      Description

      Code completion for class names in bean definitions does not work in files outside src/main/java and src/test/java for Maven projects created with the project wizard. Steps to reproduce:

      1. Create a project (File -> New -> Project... -> Maven -> Maven Project)
      2. Chose to create a simple project without archetype selection and enter project details
      3. Create a package containing a bean in src/main/java
      4. Create an applicationContext.xml in src/main/resources
      5. Pressing CTRL-Space inside class attribute of a bean definition yields "Content assist not available at current location"

      Enabling Spring Facet and adding the configuration file does not fix the problem, moving the applicationContext.xml to src/main/java, however, does.

      – Configuration Details –
      Product: SpringSource Tool Suite 2.3.2.201003230009-RELEASE (com.springsource.sts.ide)
      Installed Features:
      com.springsource.sts 2.3.2.201003230009-RELEASE

        Activity

        cdupuis Christian Dupuis added a comment -

        Hi Nils, I can't reproduce this issue.

        If I follow your steps I never get content assist for java classes. This is expected since STS/Spring IDE will only offer java content assist if at least one letter of the package or class name has been entered before invoking content assist.

        Closing this. Feel free to provide more detailed steps to re-produce.

        Christian


          People

          • Assignee:
            Unassigned
            Reporter:
            springify Nils Wloka
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: