Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-1931

IllegalArgumentException when starting Roo

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.7.1.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Steps:
      1. Open two Roo shells
      2. Close both shells at the same time

      This corrupts the ~/.spring_roo_pgp.bpg file leading to errors on the next start.

      Work-around: Close Roo and remove ~/.spring_roo_pgp.bpg.

      8-Jul-2011 8:32:38 PM org.springframework.roo.felix.JdkDelegatingLogListener logNow
      SEVERE: [org.springframework.roo.felix [38]] [org.springframework.roo.felix.pgp.PgpServiceImpl] The activate method has thrown an exception
      org.apache.felix.log.LogException: java.lang.IllegalArgumentException: java.io.IOException: invalid header encountered
      at org.springframework.roo.felix.pgp.PgpServiceImpl.getTrustedKeys(PgpServiceImpl.java:145)
      at org.springframework.roo.felix.pgp.PgpServiceImpl.trust(PgpServiceImpl.java:160)
      at org.springframework.roo.felix.pgp.PgpServiceImpl.trustDefaultKeys(PgpServiceImpl.java:103)
      at org.springframework.roo.felix.pgp.PgpServiceImpl.trustDefaultKeysIfRequired(PgpServiceImpl.java:87)
      at org.springframework.roo.felix.pgp.PgpServiceImpl.activate(PgpServiceImpl.java:80)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:227)
      at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38)
      at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:591)
      at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:472)
      at org.apache.felix.scr.impl.helper.ActivateMethod.invoke(ActivateMethod.java:146)
      at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:226)
      at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118)
      at org.apache.felix.scr.impl.manager.DelayedComponentManager.createRealComponent(DelayedComponentManager.java:95)
      at org.apache.felix.scr.impl.manager.AbstractComponentManager$Registered.getService(AbstractComponentManager.java:1148)
      at org.apache.felix.scr.impl.manager.DelayedComponentManager.getService(DelayedComponentManager.java:88)
      at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:306)
      at org.apache.felix.framework.ServiceRegistrationImpl.getService(ServiceRegistrationImpl.java:220)
      at org.apache.felix.framework.ServiceRegistry.getService(ServiceRegistry.java:322)
      at org.apache.felix.framework.Felix.getService(Felix.java:2913)
      at org.apache.felix.framework.BundleContextImpl.getService(BundleContextImpl.java:330)
      at org.apache.felix.scr.impl.manager.DependencyManager.getService(DependencyManager.java:785)
      at org.apache.felix.scr.impl.manager.DependencyManager$1.getInstance(DependencyManager.java:1039)
      at org.apache.felix.scr.impl.helper.BindMethod.getParameters(BindMethod.java:564)
      at org.apache.felix.scr.impl.helper.BaseMethod.invokeMethod(BaseMethod.java:226)
      at org.apache.felix.scr.impl.helper.BaseMethod.access$500(BaseMethod.java:38)
      at org.apache.felix.scr.impl.helper.BaseMethod$Resolved.invoke(BaseMethod.java:591)
      at org.apache.felix.scr.impl.helper.BaseMethod$NotResolved.invoke(BaseMethod.java:548)
      at org.apache.felix.scr.impl.helper.BaseMethod.invoke(BaseMethod.java:472)
      at org.apache.felix.scr.impl.manager.DependencyManager.invokeBindMethod(DependencyManager.java:1028)
      at org.apache.felix.scr.impl.manager.DependencyManager.bind(DependencyManager.java:944)
      at org.apache.felix.scr.impl.manager.DependencyManager.open(DependencyManager.java:868)
      at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createImplementationObject(ImmediateComponentManager.java:200)
      at org.apache.felix.scr.impl.manager.ImmediateComponentManager.createComponent(ImmediateComponentManager.java:118)
      at org.apache.felix.scr.impl.manager.DelayedComponentManager.createRealComponent(DelayedComponentManager.java:95)
      at org.apache.felix.scr.impl.manager.AbstractComponentManager$Registered.getService(AbstractComponentManager.java:1148)
      at org.apache.felix.scr.impl.manager.DelayedComponentManager.getService(DelayedComponentManager.java:88)
      at org.apache.felix.framework.ServiceRegistrationImpl.getFactoryUnchecked(ServiceRegistrationImpl.java:306)
      at org.apache.felix.framework.ServiceRegistrationImpl.getService(ServiceRegistrationImpl.java:220)
      at org.apache.felix.framework.ServiceRegistry.getService(ServiceRegistry.java:322)
      at org.apache.felix.framework.Felix.getService(Felix.java:2913)
      at org.apache.felix.framework.BundleContextImpl.getService(BundleContextImpl.java:330)
      at org.springframework.roo.shell.eclipse.Bootstrap.initShell(Bootstrap.java:575)
      at org.springframework.roo.shell.eclipse.Bootstrap.access$2(Bootstrap.java:545)
      at org.springframework.roo.shell.eclipse.Bootstrap$RooShellStartupMonitor.run(Bootstrap.java:619)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.io.IOException: invalid header encountered
      at org.bouncycastle.bcpg.BCPGInputStream.readPacket(Unknown Source)
      at org.bouncycastle.openpgp.PGPLiteralData.<init>(Unknown Source)
      at org.bouncycastle.openpgp.PGPObjectFactory.nextObject(Unknown Source)
      at org.bouncycastle.openpgp.PGPPublicKeyRingCollection.<init>(Unknown Source)
      at org.springframework.roo.felix.pgp.PgpServiceImpl.getTrustedKeys(PgpServiceImpl.java:132)
      ... 48 more
      8-Jul-2011 8:32:38 PM org.spr

        Activity

        aniltatikonda Anil Kumar Tatikonda added a comment -

        What is the location of the ~/.spring_roo_pgp.bpg as mentioned above. I'm not able to find it in the ROO_HOME

        mlippert Martin Lippert added a comment -

        I think this file is in your users home directory.

        mlippert Martin Lippert added a comment -

        This project has moved its issue management to GitHub Issues:
        https://github.com/spring-projects/spring-ide/issues

        Therefore we closed the majority of old issues, like this one here. If you think this issue is still valid and should be fixed or worked on, please feel free to file it as a new issue on GitHub (using the link above).


          People

          • Assignee:
            ldossantos Leo Dos Santos (c) [X]
            Reporter:
            spingel Steffen Pingel
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: