Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-1976

StackOverflowError during Webflow Validation

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.7.1.RELEASE
    • Fix Version/s: None
    • Component/s: VALIDATION
    • Labels:
      None
    • Environment:
      Windows - Webflow 2.3.0

      Description

      During project validation eclipse hangs and recommends workspace shutdown - subsequent operations cause STS to hang, .log shows:

      java.lang.StackOverflowError
      at java.util.ArrayList.get(ArrayList.java:322)
      at org.eclipse.core.internal.jobs.DeadlockDetector.reduceGraph(DeadlockDetector.java:516)
      at org.eclipse.core.internal.jobs.DeadlockDetector.lockReleased(DeadlockDetector.java:353)
      at org.eclipse.core.internal.jobs.LockManager.removeLockThread(LockManager.java:269)
      at org.eclipse.core.internal.jobs.OrderedLock.setCurrentOperationThread(OrderedLock.java:266)
      at org.eclipse.core.internal.jobs.OrderedLock.doRelease(OrderedLock.java:195)
      at org.eclipse.core.internal.jobs.OrderedLock.release(OrderedLock.java:246)
      at org.eclipse.wst.sse.core.internal.model.ModelManagerImpl.releaseFromRead(ModelManagerImpl.java:1913)
      at org.eclipse.wst.sse.core.internal.model.ModelManagerImpl.releaseFromRead(ModelManagerImpl.java:1772)
      at org.eclipse.wst.sse.core.internal.model.AbstractStructuredModel.releaseFromRead(AbstractStructuredModel.java:1076)
      at org.eclipse.wst.xml.core.internal.document.DOMModelImpl.releaseFromRead(DOMModelImpl.java:880)
      at org.springframework.ide.eclipse.webflow.core.internal.model.validation.WebflowValidationContext.getStateFromParentFlow(WebflowValidationContext.java:153)
      at org.springframework.ide.eclipse.webflow.core.internal.model.validation.WebflowValidationContext.getStateFromParentFlow(WebflowValidationContext.java:193)
      at org.springframework.ide.eclipse.webflow.core.internal.model.validation.WebflowValidationContext.getStateFromParentFlow(WebflowValidationContext.java:193)
      .. Stacktrace continues ad infinitum.

        Activity

        paulwilson Paul Alexander Wilson added a comment -

        Cannot reproduce this now. After a restarted eclipse for the second time, the problem went away.
        It might be worth noting that I have a parent flow with a view-state with the same id as the child flow.

        mlippert Martin Lippert added a comment -

        Hey Paul! Would it be possible to attach a sample project that has these characteristics? Maybe using that project we can try to track this problem down. Thanks!!!

        ldossantos Leo Dos Santos (c) [X] added a comment -

        In reply to comment #3:
        > Also
        > http://forum.springsource.org/showthread.php?129176-An-internal-error-occurred-during-quot-Building-workspace-quot

        More context from that thread by user who solved his deadlock:

        "Sorry all...wanted to let you know I resolved this. In a sub-flow, I a call to s ID that didn't exist. Once I crawled through all my flows and sub-flows...cleaned them up and specifically got rid of this error. Problem solved. Thanks all for the assistance."

        mlippert Martin Lippert added a comment -

        This project has moved its issue management to GitHub Issues:
        https://github.com/spring-projects/spring-ide/issues

        Therefore we closed the majority of old issues, like this one here. If you think this issue is still valid and should be fixed or worked on, please feel free to file it as a new issue on GitHub (using the link above).


          People

          • Assignee:
            ldossantos Leo Dos Santos (c) [X]
            Reporter:
            paulwilson Paul Alexander Wilson
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: