Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-2035

Unable to install Groovy Eclipse after installing Gradle

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Complete
    • Affects Version/s: 2.7.1.RELEASE
    • Fix Version/s: 2.8.0.M2
    • Component/s: GRADLE
    • Labels:

      Description

      Running into the same issue as originally reported in STS-1966.

      • Fresh install of STS 2.7.1.RELEASE
      • Install Gradle extension
      • Install Groovy Eclipse extension, receive below error:
        Problems occurred while performing installation: Operation details
        Operation details
        Cannot complete the install because of a conflicting dependency.
        Software being installed: Groovy-Eclipse Feature 2.5.2.xx-20110811-0900-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.5.2.xx-20110811-0900-e37)
        Software currently installed: Shared profile 1.0.0.1310203805388 (SharedProfile_com.springsource.sts.ide 1.0.0.1310203805388)
        Software currently installed: SpringSource Tool Suite Gradle Integration 2.7.0.201106290413-RELEASE (com.springsource.sts.gradle.feature.feature.group 2.7.0.201106290413-RELEASE)
        Only one of the following can be installed at once: 
        Java Development Tools Core 3.7.0.v_B61 (org.eclipse.jdt.core 3.7.0.v_B61)
        Java Development Tools Core 3.7.0.xx-20110811-0900-e37 (org.eclipse.jdt.core 3.7.0.xx-20110811-0900-e37)
        Cannot satisfy dependency:
        From: Shared profile 1.0.0.1310203805388 (SharedProfile_com.springsource.sts.ide 1.0.0.1310203805388)
        To: org.eclipse.jdt.core [3.7.0.v_B61]
        Cannot satisfy dependency:
        From: SpringSource Tool Suite (required) 2.7.1.201107091000-RELEASE (com.springsource.sts.feature.group 2.7.1.201107091000-RELEASE)
        To: org.springframework.ide.eclipse.feature.feature.group [2.7.1,3.0.0)
        Cannot satisfy dependency:
        From: SpringSource Tool Suite Gradle Integration 2.7.0.201106290413-RELEASE (com.springsource.sts.gradle.feature.feature.group 2.7.0.201106290413-RELEASE)
        To: com.springsource.sts.feature.group 0.0.0
        Cannot satisfy dependency:
        From: Groovy-Eclipse Feature 2.5.2.xx-20110811-0900-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.5.2.xx-20110811-0900-e37)
        To: org.codehaus.groovy.jdt.patch.feature.group [2.1.3.xx-20110811-0900-e37]
        Cannot satisfy dependency:
        From: Spring IDE Core (required) 2.7.1.201107082359-RELEASE (org.springframework.ide.eclipse.feature.feature.group 2.7.1.201107082359-RELEASE)
        To: org.eclipse.jdt.feature.group 3.3.0
        Cannot satisfy dependency:
        From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.1.3.xx-20110811-0900-e37 Eclipse Java Development Tools 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B (org.eclipse.jdt.feature.group 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B)
        To: org.eclipse.jdt.core [3.7.0.xx-20110811-0900-e37]
        

        Attachments

          Activity

            People

            Assignee:
            kdvolder Kris De Volder
            Reporter:
            chrisl@med-access.net Chris Lee
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: