Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-2039

NPE in CloudFoundry server component when refactoring dependency project

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: CLOUDFOUNDRY
    • Labels:
      None

      Description

      Error message 'An internal error occurred during: "Updating status for VMware Cloud Foundry..."'. This happened after a refactoring of a depenency project, but I don't really know if that's relevant.

      Stacktrace:

      java.lang.NullPointerException
      at org.eclipse.core.runtime.Path.append(Path.java:261)
      at org.eclipse.wst.common.componentcore.internal.flat.ChildModuleReference.<init>(ChildModuleReference.java:68)
      at org.eclipse.wst.common.componentcore.internal.flat.FlatVirtualComponent.addUsedReferences(FlatVirtualComponent.java:241)
      at org.eclipse.wst.common.componentcore.internal.flat.FlatVirtualComponent.treeWalk(FlatVirtualComponent.java:168)
      at org.eclipse.wst.common.componentcore.internal.flat.FlatVirtualComponent.cacheResources(FlatVirtualComponent.java:121)
      at org.eclipse.wst.common.componentcore.internal.flat.FlatVirtualComponent.fetchResources(FlatVirtualComponent.java:101)
      at org.eclipse.wst.web.internal.deployables.FlatComponentDeployable.members(FlatComponentDeployable.java:147)
      at org.eclipse.wst.server.core.internal.ModulePublishInfo.hasDelta(ModulePublishInfo.java:392)
      at org.eclipse.wst.server.core.internal.ServerPublishInfo.hasDelta(ServerPublishInfo.java:428)
      at org.eclipse.wst.server.core.internal.Server.hasPublishedResourceDelta(Server.java:1467)
      at org.eclipse.wst.server.core.internal.Server$ResourceChangeJob$1.visit(Server.java:210)
      at org.eclipse.wst.server.core.internal.Server.visitModule(Server.java:2781)
      at org.eclipse.wst.server.core.internal.Server.visit(Server.java:2765)
      at org.eclipse.wst.server.core.internal.Server$ResourceChangeJob.run(Server.java:221)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

        Activity

        thon Terry Denney added a comment -

        Sorry Dave I couldn't reproduce this NPE. Can you give me more information about the project that was deployed and also what kind of dependency projects did you refactor? Thanks for your help!

        dsyer David Syer added a comment -

        I'm not even sure if it was relevant. The project would have been one of the CF samples, probably the "stocks" AMQP one, and I refactored a JAR utility dependency.

        nierajsingh Nieraj Singh added a comment -

        Not reproducible.


          People

          • Assignee:
            nierajsingh Nieraj Singh
            Reporter:
            dsyer David Syer
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: