Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Sprint 2, 2.2.0.RELEASE
    • Component/s: None
    • Labels:
      None

      Description

      I've run through all the tutorials, found a few errors posted above. STS couldn't find the Tomcat download so I wasn't able to run all the tutorials to their fullest.

        Activity

        ldossantos Leo Dos Santos (c) [X] added a comment -

        While running Integration Testing with Spring and JUnit 4 : Could not get context handle from /Users/leods/Documents/workspace-sts-2.1.0.RC2/.metadata/.sts/content/org.springframework.tutorials.usingstoredprocedures-1.0.0/context27492.zip

        Also : Cannot initiate source download
        Caused by: java.io.FileNotFoundException: /PetClinic/lib/spring-test-2.5.1.jar (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:106)
        at org.sonatype.nexus.index.DefaultNexusIndexer.identify(DefaultNexusIndexer.java:503)
        at org.maven.ide.eclipse.internal.index.NexusIndexManager.identify(NexusIndexManager.java:214)
        ... 77 more

        ldossantos Leo Dos Santos (c) [X] added a comment -

        While running Getting Started with Spring JDBC : Could not get context handle from /Users/leods/Documents/workspace-sts-2.1.0.RC2/.metadata/.sts/content/org.springframework.tutorials.gettingstartedwithspringjdbc-1.0.0/context30503.zip

        Also : Could not get context handle from /Users/leods/Documents/workspace-sts-2.1.0.RC2/.metadata/.sts/content/org.springframework.tutorials.gettingstartedwithspringjdbc-1.0.0/context30505.zip

        ldossantos Leo Dos Santos (c) [X] added a comment -

        While running Message-Driven Beans with Spring and JMS: Cannot initiate source download
        Caused by: java.io.FileNotFoundException: /messaging/lib/spring-jms.jar (No such file or directory)
        at java.io.FileInputStream.open(Native Method)
        at java.io.FileInputStream.<init>(FileInputStream.java:106)
        at org.sonatype.nexus.index.DefaultNexusIndexer.identify(DefaultNexusIndexer.java:503)
        at org.maven.ide.eclipse.internal.index.NexusIndexManager.identify(NexusIndexManager.java:214)
        ... 77 more

        ldossantos Leo Dos Santos (c) [X] added a comment -

        Steffen to look at the cause of the errors.

        spingel Steffen Pingel added a comment -

        Thanks Leo. I have fixed the first two steps in the JDBC tutorial which were not supposed to have contexts.

        I have filed this bug against m2eclipse to track the logged error: https://issues.sonatype.org/browse/MNGECLIPSE-1593 . It does not affect running the tutorial so I'll mark this issue as resolved.

        spingel Steffen Pingel added a comment -

        In addition I have added support for double-click and filtering when selecting a tutorial from the Help > Task-Focused Tutorials selection dialog.

        mlippert Martin Lippert added a comment -

        We moved issue tracking for this project to https://github.com/spring-projects/spring-ide.
        If you would like to comment on or re-open this issue, please file a new issue at GitHub and refer to this one.


          People

          • Assignee:
            Unassigned
            Reporter:
            spingel Steffen Pingel
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1d
              1d
              Remaining:
              Remaining Estimate - 0d
              0d
              Logged:
              Time Spent - 3.5h Time Not Required
              3.5h