Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-2249

error in jstl reference validation from spring project

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.8.0.RELEASE
    • Fix Version/s: None
    • Component/s: MAVEN
    • Labels:
      None

      Description

      Reported by users on the forum:

      http://forum.springsource.org/showthread.php?116562-Can-not-find-the-tag-library-descriptor-for-http-java.sun.com-jsp-jstl-core

      I am having intermittent luck recreating it. But I did once. Then I followed the instructions here:
      http://www.albeesonline.com/blog/2008/12/09/cannot-find-the-tag-library-descriptor-for-httpjavasuncomjspjstlcore/

      and it fixed it. The fix was to slightly change the jstl reference from:

      http://java.sun.com/jsp/jstl/core

      to

      http://java.sun.com/jstl/core

      (i.e. remove the jsp component of the name).

      This addressed the issue, however, undoing the change didn't cause it to reappear!

      A relevant comment in that blog:

      Depending on the version of web application you need to use different versions of JSTL. For web application version 2.5 and 2.4, the JSTL will be referred
       
      < [email protected] prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>
       
      where for version 2. 3 the JSTL reference will be
       
      < [email protected] prefix="c" uri="http://java.sun.com/jsp/core" %>

      So it looks like we might be generating something a little odd. Although I don't know why it doesn't always fail - perhaps due to what we have in our local maven repository?

        Activity

        Hide
        aclement Andy Clement added a comment -

        As discussed here: http://forum.springsource.org/showthread.php?116566-Spring-Template-Project-Failure

        "The only other odd thing that I have seen is that when loading the template application in to a new workspace, the template app loads with an error on home.jsp on the first line which I have been changing to:
        <%@ taglib uri="http://java.sun.com/jstl/core" prefix="c" %>
        After the first error, creating subsequent projects never brings it up again."

        Show
        aclement Andy Clement added a comment - As discussed here: http://forum.springsource.org/showthread.php?116566-Spring-Template-Project-Failure "The only other odd thing that I have seen is that when loading the template application in to a new workspace, the template app loads with an error on home.jsp on the first line which I have been changing to: <%@ taglib uri="http://java.sun.com/jstl/core" prefix="c" %> After the first error, creating subsequent projects never brings it up again."
        Hide
        mlippert Martin Lippert added a comment -

        This project has moved its issue management to GitHub Issues:
        https://github.com/spring-projects/spring-ide/issues

        Therefore we closed the majority of old issues, like this one here. If you think this issue is still valid and should be fixed or worked on, please feel free to file it as a new issue on GitHub (using the link above).

        Show
        mlippert Martin Lippert added a comment - This project has moved its issue management to GitHub Issues: https://github.com/spring-projects/spring-ide/issues Therefore we closed the majority of old issues, like this one here. If you think this issue is still valid and should be fixed or worked on, please feel free to file it as a new issue on GitHub (using the link above).

          People

          • Assignee:
            Unassigned
            Reporter:
            aclement Andy Clement
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: