Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-2495

cannot install grails support to STS on Juno

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 3.0.0.M1
    • Component/s: GRAILS
    • Labels:
    • Environment:
      Eclipse Juno + STS 3.0.0 nightly

      Description

      I followed http://blog.springsource.org/2012/03/14/early-access-springsource-tool-suite-for-eclipse-juno-4-2/ and found an unexpected limitation. As far as I can see it's not possible to install the grails support.

        Activity

        Hide
        aclement Andy Clement added a comment -

        looking at this now, I presume you just dont see the option under 'extensions/sts' in the installation window after importing the bookmarks/etc.

        Show
        aclement Andy Clement added a comment - looking at this now, I presume you just dont see the option under 'extensions/sts' in the installation window after importing the bookmarks/etc.
        Hide
        robokaso Robert Kasanicky added a comment -

        Yes, as you say. I can see all other extensions there (compared to STS nightly on Eclipse 3.7), only the Grails Support is missing.

        Btw. I also don't see the extensions tab in the STS dashboard but that's perhaps expected.

        Show
        robokaso Robert Kasanicky added a comment - Yes, as you say. I can see all other extensions there (compared to STS nightly on Eclipse 3.7), only the Grails Support is missing. Btw. I also don't see the extensions tab in the STS dashboard but that's perhaps expected.
        Hide
        aclement Andy Clement added a comment -

        new build going through now - should be possible to install in a couple of hours.

        Show
        aclement Andy Clement added a comment - new build going through now - should be possible to install in a couple of hours.
        Hide
        robokaso Robert Kasanicky added a comment -

        cool, thanks!

        Show
        robokaso Robert Kasanicky added a comment - cool, thanks!
        Hide
        aclement Andy Clement added a comment -

        should be working now. I just tried it and it installed OK and I could create projects/etc.

        Show
        aclement Andy Clement added a comment - should be working now. I just tried it and it installed OK and I could create projects/etc.
        Hide
        gepsens Guillaume Balaine added a comment -

        This problem reappeared today with the following message :
        Cannot complete the install because one or more required items could not be found.
        Software being installed: SpringSource Tool Suite Grails Support 3.0.0.201205290812-SNAPSHOT (com.springsource.sts.grails.feature.group 3.0.0.201205290812-SNAPSHOT)
        Missing requirement: SpringSource Tool Suite Grails Support 3.0.0.201205290812-SNAPSHOT (com.springsource.sts.grails.feature.group 3.0.0.201205290812-SNAPSHOT) requires 'com.springsource.sts.frameworks.ui [3.0.0.201205170412-SNAPSHOT]' but it could not be found

        Show
        gepsens Guillaume Balaine added a comment - This problem reappeared today with the following message : Cannot complete the install because one or more required items could not be found. Software being installed: SpringSource Tool Suite Grails Support 3.0.0.201205290812-SNAPSHOT (com.springsource.sts.grails.feature.group 3.0.0.201205290812-SNAPSHOT) Missing requirement: SpringSource Tool Suite Grails Support 3.0.0.201205290812-SNAPSHOT (com.springsource.sts.grails.feature.group 3.0.0.201205290812-SNAPSHOT) requires 'com.springsource.sts.frameworks.ui [3.0.0.201205170412-SNAPSHOT] ' but it could not be found
        Hide
        kdvolder Kris De Volder added a comment -

        The error you have there seems to indicate trying to install a version from before 3.0.0.M2 and some of the components that it depends on such as 'com.springsource.sts.frameworks.ui' are probably no longer available from snapshot update sites.

        3.0.0.M2 was actaully released fairly recently and it is based on Eclipse 4.2. So you could try to download the new 'Groovy Grails Tools Suite' which is a prepackaged version of STS with the groovy grails tools already included.

        You can get it from here:
        http://www.springsource.org/springsource-tool-suite-download

        Go to the other downloads page and scroll down to find GGTS 3.0.0.M2 there.

        I think that's probably the easiest route at the moment to get an Eclipse 4.2 based STS with Grails tools installed.

        Also its advisable when switcing to a post 3.0.0.M2 version to do via a clean install rather than an update of a pre-existing install because the bundles and package names in 3.0.0.M2 have all changed which may cause chaos in update scenarios (e.g. having both an old an new version installed at the same time).

        Show
        kdvolder Kris De Volder added a comment - The error you have there seems to indicate trying to install a version from before 3.0.0.M2 and some of the components that it depends on such as 'com.springsource.sts.frameworks.ui' are probably no longer available from snapshot update sites. 3.0.0.M2 was actaully released fairly recently and it is based on Eclipse 4.2. So you could try to download the new 'Groovy Grails Tools Suite' which is a prepackaged version of STS with the groovy grails tools already included. You can get it from here: http://www.springsource.org/springsource-tool-suite-download Go to the other downloads page and scroll down to find GGTS 3.0.0.M2 there. I think that's probably the easiest route at the moment to get an Eclipse 4.2 based STS with Grails tools installed. Also its advisable when switcing to a post 3.0.0.M2 version to do via a clean install rather than an update of a pre-existing install because the bundles and package names in 3.0.0.M2 have all changed which may cause chaos in update scenarios (e.g. having both an old an new version installed at the same time).

          People

          • Assignee:
            Unassigned
            Reporter:
            robokaso Robert Kasanicky
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: