Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.9.1.RELEASE
    • Fix Version/s: 3.0.0.M1
    • Component/s: EDITING
    • Labels:

      Description

      I've been getting this error occasionally in STS. I haven't yet figured out how to regularly reproduce it though. I'll update the issue if I figure out how to reproduce it. In the meantime I give provide the stack trace:

      eclipse.buildId=unknown
      java.version=1.6.0_24
      java.vendor=Sun Microsystems Inc.
      BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
      Command-line arguments: -os win32 -ws win32 -arch x86_64

      Warning
      Thu Mar 29 13:22:48 MDT 2012
      The 'Spring Annotation Proposal' proposal computer from the 'com.springsource.sts.quickfix' plug-in did not complete normally. The extension has thrown a runtime exception.

      java.lang.NullPointerException
      at com.springsource.sts.quickfix.jdt.util.ProposalCalculatorUtil.hasAnnotationInParameters(ProposalCalculatorUtil.java:136)
      at com.springsource.sts.quickfix.jdt.computers.QualifierArgumentProposalComputer.computeCompletionProposals(QualifierArgumentProposalComputer.java:48)
      at com.springsource.sts.quickfix.jdt.computers.AnnotationProposalComputer.computeCompletionProposals(AnnotationProposalComputer.java:58)
      at com.springsource.sts.quickfix.jdt.computers.AnnotationArgumentProposalComputer.computeCompletionProposals(AnnotationArgumentProposalComputer.java:26)
      at org.eclipse.jdt.internal.ui.text.java.CompletionProposalComputerDescriptor.computeCompletionProposals(CompletionProposalComputerDescriptor.java:318)
      at org.eclipse.jdt.internal.ui.text.java.CompletionProposalCategory.computeCompletionProposals(CompletionProposalCategory.java:267)
      at org.eclipse.jdt.internal.ui.text.java.ContentAssistProcessor.collectProposals(ContentAssistProcessor.java:283)
      at org.eclipse.jdt.internal.ui.text.java.ContentAssistProcessor.computeCompletionProposals(ContentAssistProcessor.java:243)
      at org.eclipse.jface.text.contentassist.ContentAssistant.computeCompletionProposals(ContentAssistant.java:1830)
      at org.eclipse.jface.text.contentassist.CompletionProposalPopup.computeProposals(CompletionProposalPopup.java:556)
      at org.eclipse.jface.text.contentassist.CompletionProposalPopup.access$16(CompletionProposalPopup.java:553)
      at org.eclipse.jface.text.contentassist.CompletionProposalPopup$2.run(CompletionProposalPopup.java:488)
      at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
      at org.eclipse.jface.text.contentassist.CompletionProposalPopup.showProposals(CompletionProposalPopup.java:482)
      at org.eclipse.jface.text.contentassist.ContentAssistant$2.run(ContentAssistant.java:377)
      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
      at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
      at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
      at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
      at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
      at org.eclipse.equinox.launcher.Main.main(Main.java:1386)

        Activity

        ravi.gill Ravi Gill added a comment -

        This issue is still there, and i wonder why is this a minor issue, most of the people i have talked to working on Mac 10.6+ are facing this issue, eveytime when i use autocomplete i get the warning window popup with the above mentioned exception.

        mlippert Martin Lippert added a comment -

        What version of STS are you using? And can you post a stack trace from using the latest version? This should have been fixed since 3.0.0.M1...

        ravi.gill Ravi Gill added a comment -

        Spring:
        Verison: 3.1.2.RELEASE

        STS:
        Version: 2.9.2.RELEASE
        Build Id: 201205071000

        Trace:

        !ENTRY org.eclipse.jdt.ui 2 0 2012-08-13 20:38:17.113
        13 !MESSAGE The 'Spring Annotation Proposal' proposal computer from the 'com.springsource.sts.quickfix' plug-in did not complete normally. The extension has thrown a runtime exception.
        14 !STACK 0
        15 java.lang.NullPointerException
        16 at com.springsource.sts.quickfix.jdt.util.ProposalCalculatorUtil.hasAnnotationInParameters(ProposalCalculatorUtil.java:136)
        17 at com.springsource.sts.quickfix.jdt.computers.QualifierArgumentProposalComputer.computeCompletionProposals(QualifierArgumentProposalComputer.java:48)
        18 at com.springsource.sts.quickfix.jdt.computers.AnnotationProposalComputer.computeCompletionProposals(AnnotationProposalComputer.java:58)
        19 at com.springsource.sts.quickfix.jdt.computers.AnnotationArgumentProposalComputer.computeCompletionProposals(AnnotationArgumentProposalComputer.java:26)
        20 at org.eclipse.jdt.internal.ui.text.java.CompletionProposalComputerDescriptor.computeCompletionProposals(CompletionProposalComputerDescriptor.java:318)
        21 at org.eclipse.jdt.internal.ui.text.java.CompletionProposalCategory.computeCompletionProposals(CompletionProposalCategory.java:267)
        22 at org.eclipse.jdt.internal.ui.text.java.ContentAssistProcessor.collectProposals(ContentAssistProcessor.java:283)
        23 at org.eclipse.jdt.internal.ui.text.java.ContentAssistProcessor.computeCompletionProposals(ContentAssistProcessor.java:243)
        24 at org.eclipse.jface.text.contentassist.ContentAssistant.computeCompletionProposals(ContentAssistant.java:1830)
        25 at org.eclipse.jface.text.contentassist.CompletionProposalPopup.computeProposals(CompletionProposalPopup.java:556)
        26 at org.eclipse.jface.text.contentassist.CompletionProposalPopup.access$16(CompletionProposalPopup.java:553)
        27 at org.eclipse.jface.text.contentassist.CompletionProposalPopup$2.run(CompletionProposalPopup.java:488)
        28 at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
        29 at org.eclipse.jface.text.contentassist.CompletionProposalPopup.showProposals(CompletionProposalPopup.java:482)
        30 at org.eclipse.jface.text.contentassist.ContentAssistant.showPossibleCompletions(ContentAssistant.java:1656)
        31 at org.eclipse.jdt.internal.ui.javaeditor.CompilationUnitEditor$AdaptedSourceViewer.doOperation(CompilationUnitEditor.java:183)
        32 at org.eclipse.ui.texteditor.ContentAssistAction$1.run(ContentAssistAction.java:82)
        33 at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
        34 at org.eclipse.ui.texteditor.ContentAssistAction.run(ContentAssistAction.java:80)
        35 at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
        36 at org.eclipse.ui.commands.ActionHandler.execute(ActionHandler.java:185)
        37 at org.eclipse.ui.internal.handlers.LegacyHandlerWrapper.execute(LegacyHandlerWrapper.java:109)
        38 at org.eclipse.core.commands.Command.executeWithChecks(Command.java:476)
        39 at org.eclipse.core.commands.ParameterizedCommand.executeWithChecks(ParameterizedCommand.java:508)
        40 at org.eclipse.ui.internal.handlers.HandlerService.executeCommand(HandlerService.java:169)
        41 at org.eclipse.ui.internal.keys.WorkbenchKeyboard.executeCommand(WorkbenchKeyboard.java:468)
        42 at org.eclipse.ui.internal.keys.WorkbenchKeyboard.press(WorkbenchKeyboard.java:786)
        43 at org.eclipse.ui.internal.keys.WorkbenchKeyboard.processKeyEvent(WorkbenchKeyboard.java:885)
        44 at org.eclipse.ui.internal.keys.WorkbenchKeyboard.filterKeySequenceBindings(WorkbenchKeyboard.java:567)
        45 at org.eclipse.ui.internal.keys.WorkbenchKeyboard.access$3(WorkbenchKeyboard.java:508)
        46 at org.eclipse.ui.internal.keys.WorkbenchKeyboard$KeyDownFilter.handleEvent(WorkbenchKeyboard.java:123)
        47 at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        48 at org.eclipse.swt.widgets.Display.filterEvent(Display.java:1069)
        49 at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4127)
        50 at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1457)
        51 at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1480)
        52 at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1465)
        53 at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:1494)
        54 at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:1490)
        55 at org.eclipse.swt.widgets.Canvas.sendKeyEvent(Canvas.java:493)
        56 at org.eclipse.swt.widgets.Control.doCommandBySelector(Control.java:1060)
        57 at org.eclipse.swt.widgets.Display.windowProc(Display.java:5563)
        58 at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method)
        59 at org.eclipse.swt.internal.cocoa.NSResponder.interpretKeyEvents(NSResponder.java:68)
        60 at org.eclipse.swt.widgets.Composite.keyDown(Composite.java:587)
        61 at org.eclipse.swt.widgets.Display.windowProc(Display.java:5473)
        62 at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
        63 at org.eclipse.swt.widgets.Widget.callSuper(Widget.java:220)
        64 at org.eclipse.swt.widgets.Widget.windowSendEvent(Widget.java:2095)
        65 at org.eclipse.swt.widgets.Shell.windowSendEvent(Shell.java:2253)
        66 at org.eclipse.swt.widgets.Display.windowProc(Display.java:5535)
        67 at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
        68 at org.eclipse.swt.widgets.Display.applicationSendEvent(Display.java:4989)
        69 at org.eclipse.swt.widgets.Display.applicationProc(Display.java:5138)
        70 at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method)
        71 at org.eclipse.swt.internal.cocoa.NSApplication.sendEvent(NSApplication.java:128)
        72 at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3610)
        73 at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
        74 at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
        75 at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
        76 at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
        77 at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        78 at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
        79 at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        80 at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
        81 at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        82 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        83 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        84 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
        85 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        86 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        87 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        88 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        89 at java.lang.reflect.Method.invoke(Method.java:597)
        90 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
        91 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
        92 at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

        ravi.gill Ravi Gill added a comment -

        AH my bad, i confused the STS version with the Spring version. i'll upgrade to 3.0.

        Sorry for the inconvenience.

        mlippert Martin Lippert added a comment -

        This has been fixed in STS 3.0.0.M1 and beyond, so please update to the latest STS release (3.0.0).
        The workaround for this is to disable the content assist that is causing trouble in your environment via: Preferences -> Java -> Editor -> Content Assist -> Advanced and deselect the Spring Annotation Proposal processor.

        mlippert Martin Lippert added a comment -

        No problem at all...


          People

          • Assignee:
            ldossantos Leo Dos Santos (c) [X]
            Reporter:
            youngm@gmail.com Mike Youngstrom
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: