Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-2571

update equinox weaving for AJDT to latest from Eclipse 3.8 streams

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Complete
    • Affects Version/s: None
    • Fix Version/s: 2.9.2.RELEASE, 3.0.0.M1
    • Component/s: None
    • Labels:
      None

      Description

      We need to update Equinox Weaving to the latest version of the Eclipse 3.8 streams in order to run STS 3.0.0.M1 on Eclipse 4.2, since this error is appearing and blocking everything from JDT:

      Caused by: java.lang.IllegalArgumentException: Argument "clazz" must not be null!
      at org.eclipse.equinox.weaving.internal.caching.BundleCachingService.storeClass(Unknown Source)
      at org.eclipse.equinox.weaving.adaptors.WeavingAdaptor.storeClass(Unknown Source)
      at org.eclipse.equinox.weaving.hooks.WeavingHook.recordClassDefine(Unknown Source)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:620)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:568)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:492)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:465)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
      at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:395)
      at org.eclipse.osgi.internal.loader.SingleSourcePackage.loadClass(SingleSourcePackage.java:35)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:461)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      at java.lang.Class.getDeclaredConstructors0(Native Method)
      at java.lang.Class.privateGetDeclaredConstructors(Class.java:2389)
      at java.lang.Class.getConstructor0(Class.java:2699)
      at java.lang.Class.newInstance0(Class.java:326)
      at java.lang.Class.newInstance(Class.java:308)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:167)
      ... 185 more

      see also:
      https://bugs.eclipse.org/bugs/show_bug.cgi?id=373397

        Activity

        aeisenberg Andrew Eisenberg added a comment -

        Not as straight forward as I would have thought. Since I am using map files to grab equinox weaving and build it during the build process, I need to find a git fetch factory that knows how to grab the plugins and feature from git during a pde build.

        I think I have things working now.

        Currently, I am just grabbing an arbitrary tag that I know contains the fix that we need. Before we release AJDT 2.2.0, we should move to a stable release tag of equinox.

        aeisenberg Andrew Eisenberg added a comment -

        See https://bugs.eclipse.org/bugs/show_bug.cgi?id=376802.

        A version of AJDT with the new equinox weaving is now available. There is still some work to do on the AJDT side to make sure that the builds work consistently, but this should be sufficient for STS. Please try this out and let's make sure that this works. Then I will resolve this issue.

        mlippert Martin Lippert added a comment -

        The latest 3.0.0.M1 warmup build of STS that I created using Eclipse 4.2 and the latest bits from AJDT seems to work fine. Please also verify yourself testing the warmup build and close, if you don't see this problem anymore.

        Next question: Should we adopt this for 2.9.2 as well?

        aeisenberg Andrew Eisenberg added a comment -

        Work here is done. The new version of equinox weaving is now available in 3.0.0.M1 and 2.9.2.RC2.


          People

          • Assignee:
            aeisenberg Andrew Eisenberg
            Reporter:
            mlippert Martin Lippert
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: