Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Works as Designed
    • Affects Version/s: 2.9.1.RELEASE
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Not able to perform any software updates - getting this error "No repository found at file:filePath"

      – Configuration Details –
      Product: SpringSource Tool Suite 2.9.1.201203221000-RELEASE (com.springsource.sts.ide)
      Installed Features:
      com.springsource.sts 2.9.1.201203221000-RELEASE

        Activity

        amahmood LifeSaviour created issue -
        mlippert Martin Lippert added a comment -

        Do you get exactly this error message including "file:filePath"? Or did you put this in here as a placeholder for something else? I am asking because I've never seen this. The usual problems with accessing update sites are proxy/firewall issues. What happens when you open up the "install new software" dialog and select the STS update site from there, for example?

        mlippert Martin Lippert added a comment -

        Can you take a look at the version of the bundle org.eclipse.jdt.ui that is installed in your STS?

        amahmood LifeSaviour made changes -
        Field Original Value New Value
        Attachment screenshot-1.jpg [ 16055 ]
        amahmood LifeSaviour added a comment -

        Somehow I have 3 installed on my machine:

        org.eclipse.jdt.ui_3.7.2.v20120109-1427.jar
        org.eclipse.jdt.ui_3.7.2.r372_v20111109-0800.jar
        org.eclipse.jdt.ui.prefs

        amahmood LifeSaviour made changes -
        Attachment screenshot-2.jpg [ 16056 ]
        amahmood LifeSaviour made changes -
        Attachment screenshot-1.jpg [ 16055 ]
        mlippert Martin Lippert added a comment -

        I think my question above for the JDT version was an error on my side, please discard it. Sorry for that.

        Can you take a look at your preferences for the used update sites? (Preferences -> Install/Update -> Available Software Sites)
        Do you see anything in there that looks like the URL STS is complaining about? If so, please delete it from the list and try again.

        amahmood LifeSaviour added a comment -

        That's resolved now. Many Thanks!

        mlippert Martin Lippert made changes -
        Resolution Works as Designed [ 15 ]
        Status Open [ 1 ] Closed [ 6 ]
        tmarshall Trevor Marshall made changes -
        Workflow jira [ 42855 ] jira with Pivotal Tracker [ 66875 ]
        tmarshall Trevor Marshall made changes -
        Project Import Thu Apr 06 15:50:53 UTC 2017 [ 1491493853826 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        24d 12h 31m 1 Martin Lippert 09/May/12 4:41 AM

          People

          • Assignee:
            Unassigned
            Reporter:
            amahmood LifeSaviour
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: