Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-2623

On windows, when using 'hierarchical project names' an error ensues that ':' is an illegal character in resource names

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.9.0.RELEASE, 2.9.1.RELEASE
    • Fix Version/s: 3.0.0.M1
    • Component/s: GRADLE
    • Labels:
      None
    • Environment:
      Windows

      Description

      The problem is that pre 3.0.0 m1 hierarchical project names are generated with a ':' as a separator.
      On Linux this apparantly causes no problems, but on Windows this causes Eclipse to throw an exception because that character is 'illegal'.

      This bug was fixed a while back already (fix is in 3.0.0.M1) but there is not yet an issue that tracked this fix.

        Activity

        kdvolder Kris De Volder added a comment -

        Resolving as this was fixed already in 3.0.0.M1


          People

          • Assignee:
            kdvolder Kris De Volder
            Reporter:
            kdvolder Kris De Volder
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: