Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-3030

Roo hangs on any command (such as 'hint')

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Duplicate
    • Affects Version/s: 3.1.0.RELEASE
    • Fix Version/s: None
    • Component/s: ROO
    • Labels:
      None
    • Environment:
      - Mac OSX 10.8.2

      Description

      When I execute any command in Roo, it hangs and simply shows this message in the Progress tab: "Execute command '[command name]' on project '[proj name]'". It never finishes the command.

      I have to force-kill the process in order to stop the command. I will attach a thread dump.

        Activity

        patjnolan Patrick Nolan added a comment -

        I installed a new copy of STS 3.1.0.RELEASE and created a new Roo project from scratch to see if this could resolve the problem. It did not. New Roo projects hang on project creation, specifically this statement that runs automatically by STS: roo> project --topLevelPackage test --projectName test --java 6 --packaging JAR

        It hangs with message forever displaying "Creating Roo project: execute Spring Roo 'project' command"

        patjnolan Patrick Nolan added a comment -

        I found the solution. I was a victim of STS-1931, which appears still open and unassigned. I deleted .spring_roo_pgp.bpg and I'm now working again.

        mlippert Martin Lippert added a comment -

        closed as duplicate of STS-1931


          People

          • Assignee:
            ldossantos Leo Dos Santos (c) [X]
            Reporter:
            patjnolan Patrick Nolan
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: