Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-3078

Can't upgrade to egit 2.2 (dev version)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.1.0.RELEASE
    • Fix Version/s: None
    • Component/s: INTEGRATION
    • Labels:
      None
    • Environment:
      Linux 64 bit

      Description

      Current dependency prevents STS/GGTS 3.1.0 from upgrading egit 2.1 to egit 2.2:

        Cannot satisfy dependency:
          From: Groovy/Grails Tool Suite Package 3.1.0.201210061308-RELEASE-e38 (org.springsource.ggts.package.feature.group 3.1.0.201210061308-RELEASE-e38)
          To: org.eclipse.egit.psf.feature.group 0.0.0
      

      STS/GGTS requires org.eclipse.psf.feature but the latter will be removed in egit 2.2 because egit 2.2 will drop support for eclipse 3.5 and 3.6, see eclipse bug 365425.
      I'm developing some new features to egit and wanted to install my dev version of egit 2.2...

        Attachments

          Activity

            People

            Assignee:
            mlippert Martin Lippert
            Reporter:
            fmjrey Fran├žois Rey
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: