Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-3474

Insight fails to start on vfabric tcserver 2.9.2

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.3.0.RELEASE
    • Fix Version/s: 3.4.0.M1
    • Component/s: SERVER
    • Labels:
      None
    • Environment:
      groovy-grails-tool-suite-3.3.0.RELEASE-e3.8.2-linux-gtk-x86_64.tar.gz

      Description

      To Reproduce:
      Create new Vfabric tc server 2.9.2 in GGTS, selecting base and insight templates.
      Start server.

      Receive this error
      org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/insight]]
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:633)
      at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:977)
      at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1655)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:722)
      Caused by: java.lang.NoClassDefFoundError: com/springsource/insight/agent/dispatch/transport/impl/AbstractCollectionDataTransport
      at java.lang.ClassLoader.defineClass1(Native Method)
      at java.lang.ClassLoader.defineClass(ClassLoader.java:787)
      at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
      at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2888)
      at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1172)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1680)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1558)
      at java.lang.Class.getDeclaredFields0(Native Method)
      at java.lang.Class.privateGetDeclaredFields(Class.java:2317)
      at java.lang.Class.getDeclaredFields(Class.java:1762)
      at org.apache.catalina.util.Introspection.getDeclaredFields(Introspection.java:106)
      at org.apache.catalina.startup.WebAnnotationSet.loadFieldsAnnotation(WebAnnotationSet.java:261)
      at org.apache.catalina.startup.WebAnnotationSet.loadApplicationServletAnnotations(WebAnnotationSet.java:140)
      at org.apache.catalina.startup.WebAnnotationSet.loadApplicationAnnotations(WebAnnotationSet.java:67)
      at org.apache.catalina.startup.ContextConfig.applicationAnnotationsConfig(ContextConfig.java:405)
      at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:881)
      at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:369)
      at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
      at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:90)
      at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5269)
      at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
      ... 11 more
      Caused by: java.lang.ClassNotFoundException: com.springsource.insight.agent.dispatch.transport.impl.AbstractCollectionDataTransport
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1713)
      at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1558)
      ... 32 more

      Others having the issue at: http://forum.springsource.org/showthread.php?139582-TC-Server-Insight-not-starting-up

        Activity

        mlippert Martin Lippert added a comment -

        You should be able to use the nightly directly to update from 3.1 to 3.4 nightly builds. As an alternative, we can also provide you with a full nightly distribution build that you could install without updating stuff manually. That is usually the safest way to get a clean installation. Since the download URLs vary (because of build numbers), you would need to at least download the build quickly after I posted the link here...

        STS 3.4.0.M1 is scheduled to arrive at SpringOne2GX conference, September 9-13.
        HTH, Martin

        ganggaroo ganggaroo added a comment -

        thanks Leo your comments works!!!!

        bsamson Bong Samson added a comment -

        Hi Martin,

        I did convey to customer the alternatives you suggested. He opted NOT to go for it and will just continue to use the current work around he has at this time. Thank you for the update and suggestions you offered. - Bong

        mlippert Martin Lippert added a comment -

        OK, thanks for letting us know.
        Leo Dos Santos (c) [X] Can you set the fix version? Thanks!

        mlippert Martin Lippert added a comment -

        We moved issue tracking for this project to https://github.com/spring-projects/spring-ide.
        If you would like to comment on or re-open this issue, please file a new issue at GitHub and refer to this one.


          People

          • Assignee:
            ldossantos Leo Dos Santos (c) [X]
            Reporter:
            danieldbower Daniel Bower
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: