Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-3821

Cannot install Groovy-Eclipse Configurator for M2Eclipse

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.2.0.RELEASE, 3.5.0.RELEASE, 3.5.1.RELEASE
    • Fix Version/s: 3.5.1.RELEASE
    • Component/s: None
    • Labels:
      None
    • Environment:
      all versions are based on Eclipse 3.8

      Linux - Mint

      java version "1.7.0_55"
      OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1~0.12.10.1)
      OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)

      Description

      Try to install the "Groovy-Eclipse Configurator for M2Eclipse" extension (along with the Groovy-Eclipse extension) from the Extensions tab in the dashboard, on a clean installation of STS.

      It fails with the following message:

      "The following connectors are not available: Groovy-Eclipse Configurator for M2Eclipse"

      Happens on 3.2.0, 3.5.0, 3.5.1 (Eclipse 3.8 versions)

      Details:
      Problems occurred while performing installation: The following connectors are not available: Groovy-Eclipse Configurator for M2Eclipse (id=org.codehaus.groovy.m2eclipse.feature.group, site=http://dist.springsource.org/milestone/GRECLIPSE/e4.2/)
      The following connectors are not available: Groovy-Eclipse Configurator for M2Eclipse (id=org.codehaus.groovy.m2eclipse.feature.group, site=http://dist.springsource.org/milestone/GRECLIPSE/e4.2/)

        Attachments

          Activity

            People

            Assignee:
            mlippert Martin Lippert
            Reporter:
            mockford Ian Mockford
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: