Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-3874

Error when installing Google Plugin for Eclipse

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.6.0.RELEASE
    • Fix Version/s: 3.6.0.RELEASE, 3.6.1.RELEASE
    • Component/s: SUPPORT
    • Labels:
      None
    • Environment:
      Windows 7 64-bit

      Description

      The following error occur when selecting manage extension and click on Google Plugin for Eclipse and click on install:

      Problems occurred while performing installation: Operation details
      Operation details
      Cannot complete the install because of a conflicting dependency.
      Software being installed: Google Plugin for Eclipse 4.2 3.6.0.v201406262229-rel-r42 (com.google.gdt.eclipse.suite.e42.feature.feature.group 3.6.0.v201406262229-rel-r42)
      Software currently installed: Spring Tool Suite 3.6.0.201407101106-RELEASE-e44 (org.springsource.sts.ide 3.6.0.201407101106-RELEASE-e44)
      Only one of the following can be installed at once: 
      Core Runtime 3.10.0.v20140318-2214 (org.eclipse.core.runtime 3.10.0.v20140318-2214)
      Core Runtime 3.8.0.v20120912-155025 (org.eclipse.core.runtime 3.8.0.v20120912-155025)
      Cannot satisfy dependency:
      From: Google Eclipse 4.2 Platform Plugin 3.6.0.v201406262229-rel-r42 (com.google.gdt.eclipse.platform.e42 3.6.0.v201406262229-rel-r42)
      To: bundle org.eclipse.core.runtime [3.8.0,3.10.0)
      Cannot satisfy dependency:
      From: Google Plugin for Eclipse 4.2 3.6.0.v201406262229-rel-r42 (com.google.gdt.eclipse.suite.e42.feature.feature.group 3.6.0.v201406262229-rel-r42)
      To: com.google.gdt.eclipse.platform.e42 [3.6.0.v201406262229-rel-r42]
      Cannot satisfy dependency:
      From: Spring Tool Suite 3.6.0.201407101106-RELEASE-e44 (org.springsource.sts.ide 3.6.0.201407101106-RELEASE-e44)
      To: toolingorg.springsource.sts.ide.configuration [3.6.0.201407101106-RELEASE-e44]
      Cannot satisfy dependency:
      From: toolingorg.springsource.sts.ide.configuration 3.6.0.201407101106-RELEASE-e44
      To: toolingwin32.win32.x86_64org.eclipse.core.runtime [3.6.0.201407101106-RELEASE-e44]
      Cannot satisfy dependency:
      From: toolingwin32.win32.x86_64org.eclipse.core.runtime 3.6.0.201407101106-RELEASE-e44
      To: bundle org.eclipse.core.runtime 3.10.0.v20140318-2214
      

        Attachments

          Activity

            People

            Assignee:
            mlippert Martin Lippert
            Reporter:
            marioja Mario Jauvin
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: