Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-4237

Not able to install Eclipse Quicksearch plugin

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: SUPPORT
    • Environment:
      Windows 64bit , STS 2.6.1

      Description

      Cannot complete the install because of a conflicting dependency.
      Software being installed: Eclipse Quicksearch 3.7.1.201510040953-RELEASE (org.springsource.ide.eclipse.commons.quicksearch.feature.feature.group 3.7.1.201510040953-RELEASE)
      Software currently installed: Maven Integration for AJDT (Optional) 0.10.0.20100209-0800 (org.maven.ide.eclipse.ajdt.feature.feature.group 0.10.0.20100209-0800)
      Only one of the following can be installed at once:
      OSGi System Bundle 3.6.2.R36x_v20110210 (org.eclipse.osgi 3.6.2.R36x_v20110210)
      OSGi System Bundle 3.6.1.R36x_v20100806 (org.eclipse.osgi 3.6.1.R36x_v20100806)
      OSGi System Bundle 3.6.0.v20100517 (org.eclipse.osgi 3.6.0.v20100517)
      OSGi System Bundle 3.8.2.v20130124-134944 (org.eclipse.osgi 3.8.2.v20130124-134944)
      Cannot satisfy dependency:
      From: Eclipse RCP 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS (org.eclipse.rcp.feature.group 3.6.0.v20100519-9OArFKvFtsd7WLUKh-DcYTS)
      To: org.eclipse.osgi [3.6.0.v20100517]
      Cannot satisfy dependency:
      From: Eclipse RCP 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T (org.eclipse.rcp.feature.group 3.6.1.r361_v20100827-9OArFLdFjY-ThSQXmKvKz0_T)
      To: org.eclipse.osgi [3.6.1.R36x_v20100806]
      Cannot satisfy dependency:
      From: Eclipse RCP 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY (org.eclipse.rcp.feature.group 3.6.2.r362_v20101104-9SAxFMKFkSAqi8axkv1ZjegmiBLY)
      To: org.eclipse.osgi [3.6.2.R36x_v20110210]
      Cannot satisfy dependency:
      From: Maven Integration for AJDT (Optional) 0.10.0.20100209-0800 (org.maven.ide.eclipse.ajdt.feature.feature.group 0.10.0.20100209-0800)
      To: org.eclipse.rcp.feature.group 3.3.0
      Cannot satisfy dependency:
      From: SpringSource Tool Suite Framework Support Core 3.7.1.201510040953-RELEASE (org.springsource.ide.eclipse.commons.frameworks.core 3.7.1.201510040953-RELEASE)
      To: package org.osgi.framework.wiring 0.0.0
      Cannot satisfy dependency:
      From: Eclipse Integration Commands - Livexp 3.7.1.201510040953-RELEASE (org.springsource.ide.eclipse.commons.livexp 3.7.1.201510040953-RELEASE)
      To: bundle org.springsource.ide.eclipse.commons.frameworks.core 0.0.0
      Cannot satisfy dependency:
      From: Quick Search 3.7.1.201510040953-RELEASE (org.springsource.ide.eclipse.commons.quicksearch 3.7.1.201510040953-RELEASE)
      To: bundle org.springsource.ide.eclipse.commons.livexp 0.0.0
      Cannot satisfy dependency:
      From: Eclipse Quicksearch 3.7.1.201510040953-RELEASE (org.springsource.ide.eclipse.commons.quicksearch.feature.feature.group 3.7.1.201510040953-RELEASE)
      To: org.springsource.ide.eclipse.commons.quicksearch [3.7.1.201510040953-RELEASE]

        Activity

        mlippert Martin Lippert added a comment -

        I can vaguely identify the problem from the log output above, but I am wondering what install you are trying to install the quick search plugin into? I am especially wondering about the various versions for the system OSGi bundle that are being mentioned in the log file above. Is this a fresh Eclipse installation that you use? Or do you have additional plugins installed? I could try to reproduce this, but a few steps how to do that would be helpful. Can you provide more details? That would be great.

        rajeshgajipara Rajesh Gajipara added a comment -

        Hi Martin,
        Thanks for looking into issue.
        I am installing Quick Search plugin using below URL
        Quick Search - http://dist.springsource.com/release/TOOLS/eclipse-integration-commons/
        under that I had selected 1 component which is Core/Eclipse Integration commons --> Quick Search

        I have installed few plugins related to GWT and others.
        below is the list. OSGI might be the part of below
        Google App Engine Java SDK 1.9.18 1.9.18
        Google Plugin for Eclipse 3.6 3.2.4.v201306061640-rel-r36
        Google Web Toolkit SDK 2.6.0 2.6.0
        Graphical Editing Framework Zest Visualization Toolkit 1.2.0.v20100519-2050-67818yE6F-AA7P4B8I52322
        GWT Designer Core 3.1.2.r36x201303061525
        GWT Designer Editor 3.1.2.r36x201303061530
        GWT Designer GPE 3.1.2.r36x201303061641
        JNA Library 3.2.7
        Maven Integration for AJDT (Optional) 0.10.0.20100209-0800
        Maven Integration for Eclipse (Required) 0.12.1.20110112-1712
        Maven Integration for WTP (Optional) 0.11.1.20101108-1810
        Project configurators for commonly used maven plugins (temporary) 0.12.0.20101103-1500
        SpringSource Tool Suite 2.6.1.201105041000-RELEASE
        SpringSource Tool Suite Patches 2.6.0.201104111100-PATCH
        Subclipse (Required) 1.6.18
        Subclipse Integration for Mylyn 3.x (Optional) 3.0.0
        Subversion Client Adapter (Required) 1.6.12
        Subversion JavaHL Native Library Adapter (Required) 1.6.17
        Tracer for OpenGL ES 23.0.6.1720515
        Tycho Project Configurators 0.4.3.20101103-1630
        WindowBuilder Core 1.5.2.r36x201303061457
        WindowBuilder CSS Support 1.5.2.r36x201303061510
        WindowBuilder XML Core (requires Eclipse WTP/WST) 1.5.2.r36x201303061518

        Regards,
        Rajesh Gajipara

        mlippert Martin Lippert added a comment -

        Thanks for the additional details, that helps a lot. I can see that you have SpringToolSuite 2.6.1 installed, which is a quite old version of STS. Since the quick search plugin shares a few common libraries with STS, I guess there is an incompatibility coming up here. You try to install the Quick Text Search version 3.7.1 into an Eclipse with STS 2.6.1 and I guess that is causing the issue. I would expect that the quick text search is compatible with newer versions of Eclipse and STS only.

        I also spot a few other components (like m2e-wtp, m2e in general, m2e-ajdt, and some more) that are quite old. I would recommend to setup a new fresh Eclipse or STS installation with all the latest versions of those plugins installed in order to solve this issue. I know that this can get time consuming, but I think updating to a newer version is worth doing it.

        mlippert Martin Lippert added a comment -

        This project has moved its issue management to GitHub Issues:
        https://github.com/spring-projects/spring-ide/issues

        Therefore we closed the majority of old issues, like this one here. If you think this issue is still valid and should be fixed or worked on, please feel free to file it as a new issue on GitHub (using the link above).


          People

          • Assignee:
            Unassigned
            Reporter:
            rajeshgajipara Rajesh Gajipara
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: