Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-4305

Installation of Subclipse 1.8.x fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.7.2.RELEASE
    • Fix Version/s: 3.7.3.RELEASE
    • Component/s: INTEGRATION
    • Labels:
      None
    • Environment:
      Running latest STS on OS X Yosemite

      Description

      I have a clean install (not upgrade) of the latest version of STS, 3.7.2. I attempt to install Subclipse 1.8.x from the following site:

      http://subclipse.tigris.org/update_1.8.x

      It gets a good amount of the way along, but then ultimately fails with a message saying:

      An error occurred while collecting items to be installed
      session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
      No repository found containing: osgi.bundle,org.springframework.roo.wrapping.protobuf-java-lite,2.3.0.0001

      I even tried clearing p2 cache and get the exact same error. I am unable to do the install via Marketplace as the version there is currently Subclipse 1.10.x

        Attachments

          Activity

            People

            Assignee:
            mlippert Martin Lippert
            Reporter:
            patrickmcmichael Patrick W. McMichael
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: