Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: 3.8.2.RELEASE
    • Fix Version/s: 3.8.3.RELEASE
    • Component/s: None
    • Labels:
    • Environment:
      With every start of STS after a MacOS system restart, all of my plugin installations and configurations seems to be lost.

      Description

      Every STS start after a MacOS system restart generates a new configuration folder ~/.eclipse/org.springsource.sts_3.8.2.RELEASE... on my Mac.

      The first start of STS has generated the folder
      ~/.eclipse/org.springsource.sts_3.8.2.RELEASE_1295117626_macosx_cocoa_x86_64.

      The start of STS after a Mac restart has generated the new folder ~/.eclipse/org.springsource.sts_3.8.2.RELEASE_1729811341_macosx_cocoa_x86_64 on my Mac. All prior installed plugins and configurations seems to be lost, when STS has started.

        Activity

        pivotaltracker Pivotal Tracker added a comment -

        Martin Lippert added a comment in Pivotal Tracker:

        I am facing similar issues from time to time, but I am not sure how to reproduce those errors at the moment. Need to dive deeper into this.

        View this Pivotal Tracker story: https://www.pivotaltracker.com/story/show/132322379

        pivotaltracker Pivotal Tracker added a comment -

        Martin Lippert added a comment in Pivotal Tracker:

        This seems to be related to the way you launch/start Eclipse or STS. It happens for Eclipse as well as STS.

        If you launch Eclipse/STS on macOS by clicking on the "Eclipse.app" or "STS.app" icon, this additional folder is being created and configuration data is being stored in there (as well as additionally installed plugins). If you click on the executable inside (Eclipse.app/Contents/MacOS/eclipse), this doesn't happen and the configuration inside of the application bundle is used.

        I have no idea at the moment why this happens and reported this to Eclipse:

        https://bugs.eclipse.org/bugs/show_bug.cgi?id=507328

        Lets see if they can shed some light on this.

        View this Pivotal Tracker story: https://www.pivotaltracker.com/story/show/132322379

        pivotaltracker Pivotal Tracker added a comment -

        Martin Lippert added a comment in Pivotal Tracker:

        I made some progress on this. There seems to be a problem when STS (or Eclipse) gets translocated my macOS Sierra at first start. This translocation is done by macOS Sierra (as a new security feature) and it somehow causes STS/Eclipse to be confused and create those random folders in ~/.eclipse/. Since those random folders seem to be different every day, installation information and settings are lost.

        While I am trying to find out how to fix this in STS/Eclipse, so that it works in the translocated case, there are two workarounds for this problem.

        If you start STS/Eclipse by starting the executable directly (which is inside of the STS.app package under STS.app/Contents/MacOS/sts), the app doesn't get translocated and everything is fine.

        If you move the STS.app package after unzipping it into the official "Applications" folder of your Mac, the app isn't translocated either and everything is fine, too.

        Both are just workarounds (not real solutions to this problem), but at least there is a workaround that I hope helps you right away.

        View this Pivotal Tracker story: https://www.pivotaltracker.com/story/show/132322379

        pivotaltracker Pivotal Tracker added a comment -

        Martin Lippert added a comment in Pivotal Tracker:

        I tried to find another solution to this in the Equinox launcher code, but failed. Gatekeeper seems to do this path randomization action after every restart of the machine. Therefore the launcher just don't know whether it is indeed a newly installed app or "just" a newly randomized app.

        I detailed all my results in:
        https://bugs.eclipse.org/bugs/show_bug.cgi?id=507328#c12

        So please, to avoid this, move the STS.app bundle to a different location using the Mac Finder. It looks like it doesn't have to be the "Applications" folder, it can also be a different one on your drive (whatever fits your needs).

        If you want to verify that the app isn't moved by Gatekeeper, you can dive into the configuration details by going to the About dialog, select the Installation Details, click on the Configuration tab, and look for the "eclipse.home.location" property. It should point to the path where you put STS. If it starts with "/private/var", then Gatekeeper has moved the app to a randomized read-only location.

        I hope this helps.

        Side note: we might change the packaging of STS in the future and put it into a signed DMG file, so that our users have to move it to a location on their disc.

        View this Pivotal Tracker story: https://www.pivotaltracker.com/story/show/132322379

        mlippert Martin Lippert added a comment -

        Mark this as closed and "not applicable", since this is caused my macOS Sierra and not STS itself, as described above.


          People

          • Assignee:
            mlippert Martin Lippert
            Reporter:
            pdorff Peter Dorff
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: