Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-4409

Warning: Class 'org.springframework.integration.expression.IntegrationEvaluationContextAwareBeanPostProcessor' is marked deprecated

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 3.8.2.RELEASE
    • Fix Version/s: 3.8.4.RELEASE
    • Component/s: INTEGRATION
    • Labels:
      None
    • Environment:
      Eclipse 4.6.1 with STS 3.8.2

      Description

      I upgraded Spring Integration on my project from version 4.1.x to 4.2.x. I'm using versionless schemas in my XML bean config files. The Spring config editor prints the following warning on all XML config files that use Spring Integration namespaces:

      Class 'org.springframework.integration.expression.IntegrationEvaluationContextAwareBeanPostProcessor' is marked deprecated
      

      I suspect that the Spring Integration namespace support is still using the deprecated class, so I don't know if the actual bug is in STS or in Spring Integration, anyway it's an annoying warning popping up on all config files that use the Spring Integration namespace.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            mauromol Mauro Molinari
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: