Uploaded image for project: 'Spring Tool Suite'
  1. Spring Tool Suite
  2. STS-736

Spring roo and svn to execute a command in the "roo shell be running the light of progress of the task from running other tasks.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: 2.2.1.RELEASE
    • Fix Version/s: 2.3.1.RELEASE
    • Component/s: None
    • Labels:
      None
    • Environment:
      I'm using as an operating system to Windows Vista Home Premium, STS 2.2.1, VisualSVN to manage versioning, subversive and connector plug on STS javahl1.6, spring roo RC3 rev 401

      Description

      I started using spring roo for a college project, I find it an excellent tool for development, but now the project will be in conjunction with other developers, so it is necessary to use svn version of it.

      The problem is that when I do a check out the project, the roo shell not working properly, because after running some command such as entity, field, etc.. the sale of task execution progress of the STS is running indefinitely, so I can not run any other command.

      The steps you take after you install the whole environment for versioning the project were:
      1.-Share entire project
      2.-Then a check out
      3.-Open console roo
      4.-Create an entity with the entity command

      After doing that the problem appeared. Another thing I noticed is that in wanting to use the ctrl + space to deploy the package hierarchies that keep my body wanted nothing showed up, my top level is "com.iiefa.ipc

      1. Dibujo.jpg
        169 kB
      2. Dibujo2.jpg
        59 kB

        Activity

        cdupuis Christian Dupuis added a comment -

        This seems to be a Windows only problem as I'm unable to reproduce this on Mac or Linux.

        I need to test this on Windows to figure out what's going on.

        Christian

        rhleone Roger Leon added a comment -

        Finally I found the problem.

        Spring Roo shell is requesting that the id field and pass version of my organization to have visibility protected instead of private.

        Change this and I normally run the command -

        Thank you.

        cdupuis Christian Dupuis added a comment -

        This issue can be closed since the user has found the solution.


          People

          • Assignee:
            Unassigned
            Reporter:
            rhleone Roger Leon
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: