Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Complete
    • Affects Version/s: 2.3.0.RELEASE
    • Fix Version/s: Sprint 9, 2.3.1.RELEASE
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows 7 64-bit

      Description

      Unable to install from zip archive springsource-tool-suite-2.3.0.RELEASE-e3.5.1-win32.zip. The only chance to install is to unpack the archive into the root folder with really short name (like "x"). The default name "springsource" is too long.

        Activity

        cdupuis Christian Dupuis added a comment -

        Hi,

        can you please try the extraction with 7zip? 7zip is free and can be downloaded from http://www.7zip.com/.

        The Windows-integrated Zip utility is known to be broken (even in Windows 7).

        Christian

        darwinjob Dmitri Darine added a comment - - edited

        I do extract with 7zip. The error takes place when 7zip is copying the extracted files from the temporary folder to the destination. Apparently the coping is done via "system" copy which is not capable to handle the long file names.
        The installer (.exe) works fine, but for some reason it requires admin account to run.

        thon Terry Denney added a comment -

        Hi Dmitri, I tried extracting that zip file with 7zip into multiple folders and could not reproduce your error. Are you still having trouble unzipping the file?

        cdupuis Christian Dupuis added a comment -

        This is now fixed in 2.3.1. STS should happily extract for the most common folders with any zip tool.

        Christian


          People

          • Assignee:
            Unassigned
            Reporter:
            darwinjob Dmitri Darine
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: